summaryrefslogtreecommitdiff
path: root/dev-python/zipp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-13 11:06:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-13 11:06:03 +0100
commitbe8708090362c01c6111c4b76f1e395c14d86e00 (patch)
treebb61ca73e867522450783849eb63c9e1f0ba1730 /dev-python/zipp
parente93a38d535f2c29b55a5756d2de99425986b0bf3 (diff)
gentoo auto-resync : 13:08:2024 - 11:06:03
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest4
-rw-r--r--dev-python/zipp/zipp-3.19.3.ebuild53
-rw-r--r--dev-python/zipp/zipp-3.20.0.ebuild53
3 files changed, 110 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index c16d876933b4..04682a79c0bd 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,3 +1,7 @@
DIST zipp-3.19.2.tar.gz 22922 BLAKE2B 8f4a115079b6faa730a3502592983c13b2db27541cdbd91723fd20f320d22678f3740b01f24b46f7049607c49953ea64fa8e4855d26f28f0683d330b625a2d0b SHA512 3f1b663c4befef774e076845a8a2d2fc414cb768af0e3bccc57b6b694e9ef28e8dd8ae59b596b269f610b082e9c7a92ec3dcd465aad4e5ebe250ea96df89b2cf
+DIST zipp-3.19.3.tar.gz 23169 BLAKE2B be8ab50de2edb2262e78a7047fd06a10a31414b534a649b0ae3297d4ed843fb33141d1fc563accb4dd71b23b7ef7d161f16045139a90349dc757a72d1cf9320a SHA512 a76d50e6405b40dab4806662a26aaf0cff096a8d2462e0da9d81abd1675d64d8c520391277e8225e912a220f1e7965c754e8db24e9917343f2a0808b51a4f69e
+DIST zipp-3.20.0.tar.gz 23244 BLAKE2B cc7d336089b4659ac884658f93246045a617d223cc3db538160cef1d705e781d341f6384ab32928e7ef2c6644cf6a0656f2b6fa23077da5df0ec66d9b2337b8f SHA512 c141c4b8bdaf2ff7639cfb85ba36735da1ca33e68b9fdcb7f350e5bd677ca39def00178aa3d481c733162beed4aa70f93525800f1af0618529ff36ca7e32327e
EBUILD zipp-3.19.2.ebuild 1432 BLAKE2B 51558a95ef2c301086a8bb3b745ae02fe48b6b3439df18592c91cfef67e2f02ff6c3b49a8f7fde271cd5f136b07ff733c7aee9e98344f351cd945ad6c738cb46 SHA512 f68f4db7dd818ce44cead25e9c723c8b4172c86e422850bd6c0f952de5069eec9cadcb5fe1de815fc34b22dc2e43ebd8ffea187479759109cffda665a24906b3
+EBUILD zipp-3.19.3.ebuild 1440 BLAKE2B 8e33bb9a21fa265b628b9bdebbab4c7cd48062b89d16c053b264f41032c7b40898dc066b1aa42b30d7dfab35a4bac48155cc03f8f729208d5e8b974ed4d31701 SHA512 2bf2cf2354039510a62c94ab4bae6567911dd1940c118c03da97312b1e0c907588f9ff4b2bc84f0d466a062c857bb5cd42001d652cdf1115fd4b4d576e1d0d6a
+EBUILD zipp-3.20.0.ebuild 1440 BLAKE2B 8e33bb9a21fa265b628b9bdebbab4c7cd48062b89d16c053b264f41032c7b40898dc066b1aa42b30d7dfab35a4bac48155cc03f8f729208d5e8b974ed4d31701 SHA512 2bf2cf2354039510a62c94ab4bae6567911dd1940c118c03da97312b1e0c907588f9ff4b2bc84f0d466a062c857bb5cd42001d652cdf1115fd4b4d576e1d0d6a
MISC metadata.xml 442 BLAKE2B f16ae43bab98bfc1f62cb9d4f117ed5c01874bd856781e80a273ff200c2d4de285181d99205d82b714fbc06cdb31625d0e70c0ff8333aa985099fcf8e2e7b795 SHA512 a75626c96d34c020b591e0207d2407f76d766c85b1d2f7e76477c21f309d2c9557ed5156d40940b41d073b3f80a71d25270e08f3baadba3cd6b159806af0ab32
diff --git a/dev-python/zipp/zipp-3.19.3.ebuild b/dev-python/zipp/zipp-3.19.3.ebuild
new file mode 100644
index 000000000000..56691701c850
--- /dev/null
+++ b/dev-python/zipp/zipp-3.19.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="
+ https://github.com/jaraco/zipp/
+ https://pypi.org/project/zipp/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# big_o is only used in test_complexity, that we ignore
+BDEPEND="
+ test? (
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ dev-python/jaraco-test[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # performance tests are flaky by design
+ tests/test_complexity.py
+)
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "zipp"
+ version = "${PV}"
+ description = "Backport of pathlib-compatible object wrapper for zip files"
+ EOF
+}
diff --git a/dev-python/zipp/zipp-3.20.0.ebuild b/dev-python/zipp/zipp-3.20.0.ebuild
new file mode 100644
index 000000000000..56691701c850
--- /dev/null
+++ b/dev-python/zipp/zipp-3.20.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="
+ https://github.com/jaraco/zipp/
+ https://pypi.org/project/zipp/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# big_o is only used in test_complexity, that we ignore
+BDEPEND="
+ test? (
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ dev-python/jaraco-test[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # performance tests are flaky by design
+ tests/test_complexity.py
+)
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "zipp"
+ version = "${PV}"
+ description = "Backport of pathlib-compatible object wrapper for zip files"
+ EOF
+}