summaryrefslogtreecommitdiff
path: root/dev-python/zope-configuration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/zope-configuration
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/zope-configuration')
-rw-r--r--dev-python/zope-configuration/Manifest4
-rw-r--r--dev-python/zope-configuration/zope-configuration-4.1.0.ebuild4
-rw-r--r--dev-python/zope-configuration/zope-configuration-4.3.1.ebuild32
3 files changed, 37 insertions, 3 deletions
diff --git a/dev-python/zope-configuration/Manifest b/dev-python/zope-configuration/Manifest
index 229937fb7e63..db4c96767245 100644
--- a/dev-python/zope-configuration/Manifest
+++ b/dev-python/zope-configuration/Manifest
@@ -1,3 +1,5 @@
DIST zope.configuration-4.1.0.tar.gz 77780 BLAKE2B a3f0da446bbc858e43ccd4249c80db07b1f29df1fc31931c07bcd55116084a70b9618b15f22a8f1027e1fc53c8e2a7ba75bb3a80d8419c16cbef8f847299a3de SHA512 86bbc5ac22c61d485fcb55c4dafb5b81eaab0a08de1e5dc3cd586769323a09896e72b1e8aac790d3e8d8f93a133efd3f88a92a4b3c1075bdd0da62cd4e33c56a
-EBUILD zope-configuration-4.1.0.ebuild 1006 BLAKE2B 7532aa96211f6ce517e3aab9cf442ff84e368c0537d1275464762760870b5c2c53e025888a0f244a25bfaa3a7e1f05659d382d84a6f8a464565f4effeae902c5 SHA512 18be2804df475692b53015b7a4aa0c47975fe7b3b2032e4d9ca72dbf4ad164d214bf50033eaf1e0b7746bddcf5ebf08c875c8548ba25d7dea33f34557e1f83b2
+DIST zope.configuration-4.3.1.tar.gz 83223 BLAKE2B 9c55951932f34484fa6760a6a3cbdf89fbf8723c43b9b4ea2cf909b74716bcdd74d03327fc418f43bcfc8b6b5c17554cf8d062952d8d6880e49e6b270da9c1c8 SHA512 bc8edf84a391cab4f664ea3a4d24b65cb9db351c972b6118e69fe3c726bbe3337121ff59d687dddf463b3672ed6996f21d4437941c81dc456a4e5d837e0945d2
+EBUILD zope-configuration-4.1.0.ebuild 1002 BLAKE2B 26b763a4a356e7e719eeecfb955426774e08a44aa345c8b2caa892c2c9a72bce486823d46ad2fc4a4b97632ef16b91b8fdc113e65118fc60a724bdaaac427158 SHA512 7c7da37a1042f547d4f6a7b7285edd8aec95c8d618cc7b72785a60c901ae06534a1388d61564bda6a76ae55a7c69e993cb7aa89b5fea9fd95f5a77ea3e6ed82d
+EBUILD zope-configuration-4.3.1.ebuild 848 BLAKE2B 0bc69b75454af2640f60741988179491845cb78aafa026cbbf467fbaa54720b29810613637cd24a41962afe0808b2434f718cf5347268d3b6577c8069d6e4bc7 SHA512 b5ea2834754882221666fab02aa4f0c1e6b515bc4f1bbae804b2f6621a5491b6986f95f11eecefc246f52c879c0c06e2c48014a1682e04d31596c15c59347e3e
MISC metadata.xml 646 BLAKE2B c556a67d6a337d654d52e94060d0a91587cf3ef8fe95fdc8808f0ed03328a26c2aeb91dc459182fcfbcd1300d38f6f70f8e7489ddd41b788205da6545934cc3b SHA512 a8660b5d1a2619030fe32a06a95ae75e83f923a0c0b63a736a3c1c95137a99aa447c85fc0665efb7196a014a5473cd47a33744ab6cd047a8d9f33deb401e06d6
diff --git a/dev-python/zope-configuration/zope-configuration-4.1.0.ebuild b/dev-python/zope-configuration/zope-configuration-4.1.0.ebuild
index 6e6336e5cf0a..f21f3228d8b7 100644
--- a/dev-python/zope-configuration/zope-configuration-4.1.0.ebuild
+++ b/dev-python/zope-configuration/zope-configuration-4.1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=(python{2_7,3_5,3_6})
+PYTHON_COMPAT=(python{2_7,3_6})
inherit distutils-r1
MY_PN=zope.configuration
diff --git a/dev-python/zope-configuration/zope-configuration-4.3.1.ebuild b/dev-python/zope-configuration/zope-configuration-4.3.1.ebuild
new file mode 100644
index 000000000000..fe5dcefb34b1
--- /dev/null
+++ b/dev-python/zope-configuration/zope-configuration-4.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_6,3_7})
+
+inherit distutils-r1
+MY_PN=zope.configuration
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope Configuration Architecture"
+HOMEPAGE="https://github.com/zopefoundation/zope.configuration
+ https://docs.zope.org/zope.configuration/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ >=dev-python/zope-schema-4.9[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}