summaryrefslogtreecommitdiff
path: root/dev-python/zope-exceptions/zope-exceptions-4.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
commitafa8da78d8135ca28150730e9c60af9d875f0a5b (patch)
tree65e94479f29d7591a1bc1d09d1fc1913d785fe6b /dev-python/zope-exceptions/zope-exceptions-4.5-r1.ebuild
parent4828c25c25aacf399de429d381288982fd7e0d0e (diff)
gentoo auto-resync : 14:11:2022 - 06:50:13
Diffstat (limited to 'dev-python/zope-exceptions/zope-exceptions-4.5-r1.ebuild')
-rw-r--r--dev-python/zope-exceptions/zope-exceptions-4.5-r1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/zope-exceptions/zope-exceptions-4.5-r1.ebuild b/dev-python/zope-exceptions/zope-exceptions-4.5-r1.ebuild
deleted file mode 100644
index 89ee54d44763..000000000000
--- a/dev-python/zope-exceptions/zope-exceptions-4.5-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-MY_P=${P/-/.}
-DESCRIPTION="General purpose exceptions for Zope packages"
-HOMEPAGE="
- https://pypi.org/project/zope.exceptions/
- https://github.com/zopefoundation/zope.exceptions/
-"
-SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-
-RDEPEND="
- dev-python/zope-interface[${PYTHON_USEDEP}]
- !dev-python/namespace-zope
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # strip rdep specific to namespaces
- sed -i -e "/'setuptools'/d" setup.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- distutils_write_namespace zope
- eunittest
-}