summaryrefslogtreecommitdiff
path: root/dev-python/zope-exceptions
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-08 00:08:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-08 00:08:11 +0100
commitadc09cc4e6ebf7931735c02c0c272b4b885c2b30 (patch)
treed1e752b60c2ed90ae9e427cbe2b07061e3879191 /dev-python/zope-exceptions
parent941687623283212199cbe6e36f7d61b89d6222b2 (diff)
gentoo auto-resync : 08:06:2024 - 00:08:11
Diffstat (limited to 'dev-python/zope-exceptions')
-rw-r--r--dev-python/zope-exceptions/Manifest2
-rw-r--r--dev-python/zope-exceptions/zope-exceptions-5.1.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/zope-exceptions/Manifest b/dev-python/zope-exceptions/Manifest
index efbca5e577a0..ab50b88800b7 100644
--- a/dev-python/zope-exceptions/Manifest
+++ b/dev-python/zope-exceptions/Manifest
@@ -1,3 +1,5 @@
DIST zope.exceptions-5.0.1.tar.gz 30435 BLAKE2B 66775ace483da20614aa4db31d106f70af5a118cd7b5f3cc3458515cf443cd6c6e0bda26b0817adf063c52ded25ffcc09b722840e90f4975976e54c48763bbf1 SHA512 46ab45feb81682b62f4ab0df31e39b8b438af593d8880eb095fb2994ce6aced5aceb2cb08973234077d9c3846adc57658e06e04aecf55443bf3af691d728291a
+DIST zope.exceptions-5.1.tar.gz 31416 BLAKE2B 62e5ddc72f36349a6e4810ee6932dbe9e80fb3c3ac5171cebcb4433832d593bf01edfbd573a5f2dc7546599d018144d28a2968598c3c43e72e3b7639e96f13bf SHA512 08e0b3b895089b35805519002f11302e6529d12257a5582f682257c4b5313c4e183d2b06241729fe542fcd407b1f29fbd6798605930b759daca335ed3df84652
EBUILD zope-exceptions-5.0.1.ebuild 949 BLAKE2B 71640d4e0d292d96979af26d4f45797115d8c32810f8ca3161a97673655a0acd9ce4db591483afa5b87cf59b8e0d22143bf36a617bf8c9dc5290329b1e0bb00b SHA512 bd3b648b01e67be3b12a1e6585fa01fd99d1de607e1ac4e921bf8e9e8e9de6fef5217891a032de100c3e5bf9f24b68a911b1c03a7b64072faa2e3b037461d832
+EBUILD zope-exceptions-5.1.ebuild 949 BLAKE2B 7e399f52cddd428d1b73ed57cab90813b36731f23d380780fb9877a80b1827a56b3ae57074a50c15a9e8919c41e0f2dfa8c30ef35c64dff0615b2dc2e485a1b0 SHA512 741fb733dabc8d5f512c1c5541b575dc2fab3973a86db6cda256a496b7f3cfad1575593b74ffcabda73e59a003ff11e48a1318926470b7073ab7e096796fa369
MISC metadata.xml 413 BLAKE2B 3bed6e3e8732f8e04efffe7ea279eaedbfef2fa2d011f1881fdfa814406b0ed5e5a926eeb1a0e66858c1f0524d5c1d1948313c50c53d9fce6cc4596ddea9f87f SHA512 ec4b63a6791605b6c66649026a10d0bc445849b801e9e6350c1bb06b7a244c86aa558830ba39dc1a3d35b3dc2d650d1a52cbe7f84c912f5f7711fe6ec6bf55c4
diff --git a/dev-python/zope-exceptions/zope-exceptions-5.1.ebuild b/dev-python/zope-exceptions/zope-exceptions-5.1.ebuild
new file mode 100644
index 000000000000..7bf7eb05d7af
--- /dev/null
+++ b/dev-python/zope-exceptions/zope-exceptions-5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="General purpose exceptions for Zope packages"
+HOMEPAGE="
+ https://pypi.org/project/zope.exceptions/
+ https://github.com/zopefoundation/zope.exceptions/
+"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ !dev-python/namespace-zope
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ distutils_write_namespace zope
+ eunittest
+}