summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 13:38:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 13:38:19 +0000
commit1d6bc233e81d1ece6bcd5d781ed786208395d19d (patch)
tree7160f86eceb686bbb5da77a48b2134e0fa11053d /dev-python
parentd46d1d3a5897cade51811b3848c7bf27969da625 (diff)
gentoo auto-resync : 28:12:2023 - 13:38:18
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin269176 -> 269192 bytes
-rw-r--r--dev-python/a2wsgi/Manifest2
-rw-r--r--dev-python/a2wsgi/a2wsgi-1.10.0.ebuild30
-rw-r--r--dev-python/boto3/Manifest2
-rw-r--r--dev-python/boto3/boto3-1.34.9.ebuild64
-rw-r--r--dev-python/botocore/Manifest2
-rw-r--r--dev-python/botocore/botocore-1.34.9.ebuild68
-rw-r--r--dev-python/coverage/Manifest2
-rw-r--r--dev-python/coverage/coverage-7.4.0.ebuild98
-rw-r--r--dev-python/pyarrow/Manifest2
-rw-r--r--dev-python/pyarrow/pyarrow-14.0.2.ebuild72
11 files changed, 342 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 36a3503818dc..26ed1ec3bfb7 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/a2wsgi/Manifest b/dev-python/a2wsgi/Manifest
index f84bffc56f61..faff6eb38705 100644
--- a/dev-python/a2wsgi/Manifest
+++ b/dev-python/a2wsgi/Manifest
@@ -1,3 +1,5 @@
+DIST a2wsgi-1.10.0.tar.gz 17811 BLAKE2B f88c243b2141c1ec04eb1447714f66384cd9dd630a081233f801779cc2abbebc1bcf479f3f5311e2f4b7a33ab549cce7197f78a8cf79221f6fe38131d2bd41e5 SHA512 fa92e7cdbcfe1a4ece72ce39c4d718b50f3e6b78daf0c85cbe7b933bca5dcc6d5e27d4004f58d8ce83fdaf7fcb43f25fbd481a0f5f4141f42d72ec5757dc1ab9
DIST a2wsgi-1.9.0.tar.gz 14435 BLAKE2B d0847d0bd1d7c8c834c243afcac2ddb342eb9a29469eb258dfed751e6629c98d0a81b5c84b7af6583b303a5a3b407d8bfb6a04a63e0c3606f0d564c55780f5d2 SHA512 e940e75c666635d842aad651d99335f5cafe8b4c236c9a47882ce5cf859cf5cfb6aa736028246139d8e06ac2b9ab53d0fd4e94ac2dbc2aa55a0103633edb0423
+EBUILD a2wsgi-1.10.0.ebuild 719 BLAKE2B 329b7c837574326528195954e36265fadc6e2790844f24bc483f7a49297d083f9988c944f16426e90232ae598f21fb630aeb42b49e08f557e7e07a122a871484 SHA512 52552410fc143d49bc205157eb81b9aaac86e3bea02eeb0946b164956f7f960ffb1f088c76676f48a2245c15dabc2091bccbe272e36768ecc38ac562082b84c6
EBUILD a2wsgi-1.9.0.ebuild 711 BLAKE2B 8dbed1ed07863a09a916e5da79c4f0bbdf2bce578575e6f1d6f2e0eb6b3924fa6c111a64d371662e100d3ea90e5d0ce513684e9d462e9ef867f49fd3e0f7c539 SHA512 f51dc0675a782f935a80fa0eec7859bc36bae40c8182cd82738bc2020ab64d78c49e6689cc9bc2c9c1d0876788788411a5c0b1b0e0788781c73492307ca34770
MISC metadata.xml 392 BLAKE2B 17f9cfa46eeac0752f6e27d004a04173528f5033dee30ba31bb9b0d86231b3311937e0765cba3cae0fcc8b9653654c9b53bbc009f15140db0b38496856b9c27e SHA512 828436206a1e9b01df9da1546ffc8e6bc614e71708ad8a806dda9ab2dad80c86e539c37496a0c2525f0370e9ead3131bbde69f235da83331cd5097985981006e
diff --git a/dev-python/a2wsgi/a2wsgi-1.10.0.ebuild b/dev-python/a2wsgi/a2wsgi-1.10.0.ebuild
new file mode 100644
index 000000000000..0dc9304f2b78
--- /dev/null
+++ b/dev-python/a2wsgi/a2wsgi-1.10.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert WSGI app to ASGI app or ASGI app to WSGI app"
+HOMEPAGE="
+ https://github.com/abersheeran/a2wsgi/
+ https://pypi.org/project/a2wsgi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ <dev-python/asgiref-4[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.2.7[${PYTHON_USEDEP}]
+ <dev-python/httpx-1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index cd491b4eb9c1..34c4e0d9db47 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,9 +2,11 @@ DIST boto3-1.33.11.gh.tar.gz 754430 BLAKE2B f206c6eeb9859af85f09bb48298b941fc0c9
DIST boto3-1.34.2.gh.tar.gz 756227 BLAKE2B 7253c533bac45b3848ab573d4781cf68b6bea8d504f851b58366dd3e6ac05b35fb2a85cb7aaff0e426a6bd2f9fe2933dd240e4d0283e4491e095fa93b4061971 SHA512 06eaf9b6725d312d91a4a8ba3ab85dde5f579e6d2fa42211189a6f30584b7d2a5c0cca46264bda52a076c8bd1acac9ec0476eb5d986a8e29972f69b7007de3c2
DIST boto3-1.34.7.gh.tar.gz 759909 BLAKE2B 059228d7bd57ac34274437f77b3510dff6dca7d1293ffd6f7672b0fcc0acefffeeda2c5c2b4e19ef49bbffd4746dc226edfba52d57f5f8629516c9e830dbdd90 SHA512 43395937977ad3c860ede35d2adbb9575312ddab4972b8d258e41a7d6e86f3e6a74037dadb0f0e0f4f3d5ed715a66390041ac9c980bc8a3cfb727a44e252113e
DIST boto3-1.34.8.gh.tar.gz 759987 BLAKE2B 32cbc7c5e82b36b7df2435f52c3f01e939c997671e8ec323840cff1554fcd84be41e1c4d17ab9b1b2779b94f815e597f8021380196c2debfb18db6fad0434cc9 SHA512 db33fb1c95f856a0a20625132e05c632baa46b3b0aacb97c9f6857a79656978abecaffd3f164b7f3eabf6e5e80f663386ab522e96c4546352bb6af6025d23fdd
+DIST boto3-1.34.9.gh.tar.gz 760016 BLAKE2B 93d036dbcd96953f8a7f9891170a58a1ac8947904ebbcd1c7fbc4ede2e21999f49f3de1a2b980253b0e671997ba0d72e24ba42ad5ab80b7d1754a769b015b005 SHA512 ffeccce1f4c97ba267291f610f6d69166b95107d02b54be53d286c3af8b3826f92d76c7454f82435bab9c7c152e1d21c0bffd21e595c26d408409942e38f8457
EBUILD boto3-1.33.11.ebuild 1385 BLAKE2B f6d6e7b258b527c1e7a57786099abb9005e340c92274e49d558ff3a9d67a50a77156fb5f2534228b3ae0e24dc25d55f6b8953bcf69758f40f22116aa88086d32 SHA512 302bdcaa8f42a84de4b2c3f2f5b87d03a72704c6304d0b0a846645ae0f9f275ce8f8b21eaaa38e6d8e1c778f7216a1ddd4b784a8c7b36a71507d52dad7339966
EBUILD boto3-1.34.2.ebuild 1392 BLAKE2B ea90aaab716898835c964275be5d02e9aa02b21b5d693766dc6b04aed3c182effd0958a1bfbdb0a6b8ec626e665b60284ebb9a6b863eb8360e016fcddfb86645 SHA512 242e5a31167f35c84e350d3299a5362f3a9b14bab745d11877bdfb05d581bb8d6e2a4baa07b8b32fa81248152068e3cf0a196aba20b4c29e49090daf9e1c6550
EBUILD boto3-1.34.7.ebuild 1393 BLAKE2B e6e26eacfc0623a93e310b3e33f75520f912d0c3139a8a6f1dbf657664058bce520d90fb6bcffb601c58bf171a05b48abd0ecb5e64bf5d6953c00f1206691bef SHA512 ebdcc8800a6552fa25d586cf586040e2b3da9fd670ae8e346e558fff4941b68dc90c8cfa5ffd6dcbdbc956878793835b950d2dc2198a3ae619c3fed58b5d785a
EBUILD boto3-1.34.8.ebuild 1393 BLAKE2B e6e26eacfc0623a93e310b3e33f75520f912d0c3139a8a6f1dbf657664058bce520d90fb6bcffb601c58bf171a05b48abd0ecb5e64bf5d6953c00f1206691bef SHA512 ebdcc8800a6552fa25d586cf586040e2b3da9fd670ae8e346e558fff4941b68dc90c8cfa5ffd6dcbdbc956878793835b950d2dc2198a3ae619c3fed58b5d785a
+EBUILD boto3-1.34.9.ebuild 1393 BLAKE2B e6e26eacfc0623a93e310b3e33f75520f912d0c3139a8a6f1dbf657664058bce520d90fb6bcffb601c58bf171a05b48abd0ecb5e64bf5d6953c00f1206691bef SHA512 ebdcc8800a6552fa25d586cf586040e2b3da9fd670ae8e346e558fff4941b68dc90c8cfa5ffd6dcbdbc956878793835b950d2dc2198a3ae619c3fed58b5d785a
EBUILD boto3-9999.ebuild 1588 BLAKE2B bfcf68e1a1dffa36c71f030ad8743b59c9170c34a425a7982ee81d1fb0df1c29fdecefa7b55f373557b735d60ab51d510ca398edd4045def5fffb6d4d4d9d579 SHA512 1bca684f585a51d8b58a594c71974b36b145912550f051d6d4c84ba28bce949ec10c112a6f7bfa8f60fa362d9126d9a830243ab36595754bef02f19e02161bb8
MISC metadata.xml 493 BLAKE2B 7d6324fc877ffe1d20c5369c2af0b09a7028f94d28f1841188913d0d8be7ea699c9d3f92c624992c4c96bd69615d3a1211a2483c76c56b7d3082492e43512523 SHA512 44420d8c03d5986f990b76369edfa8dfd7659b4952db3ad946fd05392ec594628a28745ad888d055d4f074d5214f61fcffafe6c04c4ab54109d45ac0371582bd
diff --git a/dev-python/boto3/boto3-1.34.9.ebuild b/dev-python/boto3/boto3-1.34.9.ebuild
new file mode 100644
index 000000000000..a61cfcefea34
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.9.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 27837e629e14..eeb9745c9390 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,9 +2,11 @@ DIST botocore-1.33.11.gh.tar.gz 12536159 BLAKE2B bce09ad1b93210667e3c1058ab3b435
DIST botocore-1.34.2.gh.tar.gz 12564834 BLAKE2B b22a3d3bd35b769a28ccb1a5116428e1904d0c9fc3452829237704dbec37a31a539f044a728b0785d09406d299d522dd601da39801249747d54e6741b46cafe2 SHA512 a3f3718bf584a871abbb3edc803de9d5329da257c050d56bdbf8a6a6c4067477812582fbd8d1d789ce18ea1f416d0ddb2be9cc3c45172292d061a94a12f3977b
DIST botocore-1.34.7.gh.tar.gz 12606475 BLAKE2B 387ee7dfab43c44c39c7b0566b6ddcb2b666024b5b7bee2c996194988781c169e1e9462b36d09861d1c3ca899d263392f3d79129e7a2f2fc4bbfed402f5c7dd6 SHA512 3f162d4d028dd81da552e0117671971aa891bf8fab513730f40083660fa83c1f82bf1b52875cf9f7f11089ecdd79f084f3c8e76227aa826c1aac7e5735032450
DIST botocore-1.34.8.gh.tar.gz 12607766 BLAKE2B df29d3846dcb5096708223b5b4c59a2f9a7dcf213c5691bf0a619fb4c9c6ceab5fbecefce6f8ddd76752b420fcfb95bfc7ae00c933172a7f1d9281b7b08f3049 SHA512 4359320cc619cde5bf938cec00b430f6daa8bfeb0170bb476dd3a6be0ba3464aeccd6a422e4d1487a1d7ed6721cb2ffdc55465d289fcccb82f3a5ff142b782b4
+DIST botocore-1.34.9.gh.tar.gz 12608788 BLAKE2B 2c911476db3832d44d71d0cc3fec3ac1682604168ccf3f8f31e79551b8a9e90d2dbb0c9f1cbc4b5aa3aa3a21751a41620354c1a3df1ca115bd2566ba2ebe9823 SHA512 cd20b9c0dc326f02ae61182a6cfe10dd1c3c12ccfbd760b207080bf3ba3ae7ef8ffd64bd8e909913c11156c234c0ca53ded7354c30ccc490a9e2a378a17dac5f
EBUILD botocore-1.33.11.ebuild 1517 BLAKE2B e056da584f834fcb5026f593a9187a613e82f1a6cb8df7b6fff6a997b971905e62ee8cfe8c99a0dbf1a6c514499860d8cb0a0d27e9155715ec07de46a8d8b325 SHA512 f5fd3af7a1209b7ecd8e7b8ac4aad92ae0db0477678d02c88394aeb7b9d1984e6c0975cbc4d006cc2df480f7fbec625ad8dd660edabf148dd44c2785085b9366
EBUILD botocore-1.34.2.ebuild 1524 BLAKE2B 8a2471391e1a0e596e0b8d72ee09df50c3763a3d03db51169f45b1b571ba3df97eef93a43374b196ced5e1dc978bc2f3de52099675a6b19c1d5fe933922466b3 SHA512 bdde6ff5fcea64cad2e42bf6b2e8cb49f096ed5b17c321246651936878ff07347f4fea7805bb7083053aab2014c3e4a50fefcb727e89ccee3aa6a5860d71b249
EBUILD botocore-1.34.7.ebuild 1524 BLAKE2B 8a2471391e1a0e596e0b8d72ee09df50c3763a3d03db51169f45b1b571ba3df97eef93a43374b196ced5e1dc978bc2f3de52099675a6b19c1d5fe933922466b3 SHA512 bdde6ff5fcea64cad2e42bf6b2e8cb49f096ed5b17c321246651936878ff07347f4fea7805bb7083053aab2014c3e4a50fefcb727e89ccee3aa6a5860d71b249
EBUILD botocore-1.34.8.ebuild 1524 BLAKE2B 8a2471391e1a0e596e0b8d72ee09df50c3763a3d03db51169f45b1b571ba3df97eef93a43374b196ced5e1dc978bc2f3de52099675a6b19c1d5fe933922466b3 SHA512 bdde6ff5fcea64cad2e42bf6b2e8cb49f096ed5b17c321246651936878ff07347f4fea7805bb7083053aab2014c3e4a50fefcb727e89ccee3aa6a5860d71b249
+EBUILD botocore-1.34.9.ebuild 1524 BLAKE2B 8a2471391e1a0e596e0b8d72ee09df50c3763a3d03db51169f45b1b571ba3df97eef93a43374b196ced5e1dc978bc2f3de52099675a6b19c1d5fe933922466b3 SHA512 bdde6ff5fcea64cad2e42bf6b2e8cb49f096ed5b17c321246651936878ff07347f4fea7805bb7083053aab2014c3e4a50fefcb727e89ccee3aa6a5860d71b249
EBUILD botocore-9999.ebuild 1599 BLAKE2B 8325845842cef976827216365bd3f88b7865bb4ce82764b121a42bb99d98952042223281fa66e6e31ec83e39c4fc585672fbab6426a7df79aa945df720d42a1b SHA512 ade15b4567ae00f08a0f5895d967ad3f37af15c24b3169e9319fd7d3c3a3316f34d989b225a928c8c72c2656e4c8f79d61e8b7ddd17e179adf7ff67bcbac6efb
MISC metadata.xml 499 BLAKE2B e5aaa7da26f200c09adfdf38b68f656bbccbec627cb5d966b280ac2165334e7eec659c89075bcace748f58e2ec3e7d2998e54a688d56ecea2d30653c67dfd35a SHA512 103c554d5dbd967bf9b6e418b3913d9235e7e910d012160909ce0715134ed2e37b06e6a345395f9d16ce08d1cf51f3ce458bce93c6a978fd3dca6610f2acdbd0
diff --git a/dev-python/botocore/botocore-1.34.9.ebuild b/dev-python/botocore/botocore-1.34.9.ebuild
new file mode 100644
index 000000000000..05766e84276c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.9.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index 15c7cf1d70b7..2b31803f6223 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,7 +1,9 @@
DIST coverage-7.3.2.tar.gz 764541 BLAKE2B 5301a45a1618582d6b7bc1c887fdfdc7ef612082675b271e5ab840f2adc357c6a01f59ba5571e6dba61db61c85ee66d40af46b3509dfbf5c996fcf9fd6b2a614 SHA512 94e3b0bae2f84d31448a717f105e4f03e485a47d9498e73e86eca2f040d0980e514e3d9264f5349f70ea93fc985161d89156d0faa444d28cc7a07e51db4e1a46
DIST coverage-7.3.3.tar.gz 768726 BLAKE2B 0de19dc69341ba98b0581be6c6c4844f699689d9e071e3f473a4de65f4f7d1e8bf673a18428f1d5fe23150068636c1e0b7f8e84d9a8626488aba23a998265857 SHA512 758090c46bac90096d5fd732aa447c91d0db0c0cdedbb607a57141c86882c23d42791b75e55436e580dffdd585d87e35a213e94240268c2992c1122246e4df31
DIST coverage-7.3.4.tar.gz 769564 BLAKE2B 6fb3faac8703f95632e53b4a2e3ad5544488e19cb3ea96a288cded02ac8aaf434ee8fba8c1ed3cdf89265113ae45cb7b9882202dc230dc6a416487f09317ba82 SHA512 74c371b24ff5959f9c5d100f35b09ce10c70c03f3713c29aa251c1ce4244e302c29e0cc2f54f6ff6909634a363896bfbd61abe871c062c8b78c892efbc1d2d79
+DIST coverage-7.4.0.tar.gz 776507 BLAKE2B ea96db033e711c5b47ebbd585f1eec8e576908dfbecd7df6e555a5e96cdbadf546e0b2b1a5790fd66be386a068ced5a1544dff79601546fe6a4ac0e9b36a05a2 SHA512 7563ca34ed8d0dd3b9f376b20cbaeb9c952ba0dda57d9f1a33abe94ac17ed6411d0d537f039613c310957eb926e8fa102ad888c5de8bdb3f0233668bdf96d395
EBUILD coverage-7.3.2.ebuild 2026 BLAKE2B 886fdfdcc5139439f217ff82edf89f77cd9899b208350ac6373b33f88d2cb46db6c7eb4a295f42dd096f9bcd74345adf9e8433b17608358e034672a19c41c71c SHA512 8b5f83577f9a9b6a49048ef7240abcdb4acc77d70a538cb7e5c16e98d408247e5ec70730c3dc197cd480e10e83d6dfb56d52fc648aeffcf4aee48b4d9957f091
EBUILD coverage-7.3.3.ebuild 2095 BLAKE2B f6763311edb9870ae24b078520325db3947fe83ed248eb6c3b799532f18456e9c476356958200224b7fbed4ae8ff788c3b3730975441c002c9fe70039a0111d0 SHA512 dcee3e9bfa960d4ba70536e52f3be03b07d87f3b75296f39ab468b87fc9cd478d77f4c5f38709c0f693693f284033781406063811009a0be35166618ba1dc95e
EBUILD coverage-7.3.4.ebuild 2095 BLAKE2B f6763311edb9870ae24b078520325db3947fe83ed248eb6c3b799532f18456e9c476356958200224b7fbed4ae8ff788c3b3730975441c002c9fe70039a0111d0 SHA512 dcee3e9bfa960d4ba70536e52f3be03b07d87f3b75296f39ab468b87fc9cd478d77f4c5f38709c0f693693f284033781406063811009a0be35166618ba1dc95e
+EBUILD coverage-7.4.0.ebuild 2476 BLAKE2B c9f27fcaed232d8028a6a8b8db2ffe196075fcfd358f46d482fc6af5a645a700f26cab17686b8d0f306c2f4de80f636f91b1330bd6212073f56f7f66bd509981 SHA512 fdecdaa87d6cb3b45029bff3e2eccdef0584b8a1cea573bd3dd4358cd6033fcd8c2faa5588b42792b19f538cd9d5ea2b7a20c8186aa5aa745a50cd81c99103ed
MISC metadata.xml 771 BLAKE2B 38e9680d0851f70050aad987714a9dd2f95178b0bc3d794dc08726c0618d1ea98be32a413ac397f4b222e8a5d8fdc747b7f1677bcfe842bac4080537e85a03a9 SHA512 8c44c40348fe5d416d8b4016fe22cc9ae0b94fbaf181deb79aa737f87271992521b710c1208d0eeb7ef92d96fc8a7daac1ec6feb1ae081a80f13327b5b094064
diff --git a/dev-python/coverage/coverage-7.4.0.ebuild b/dev-python/coverage/coverage-7.4.0.ebuild
new file mode 100644
index 000000000000..f41bcfc267b9
--- /dev/null
+++ b/dev-python/coverage/coverage-7.4.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="
+ https://coverage.readthedocs.io/en/latest/
+ https://github.com/nedbat/coveragepy/
+ https://pypi.org/project/coverage/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/s:-q -n auto::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+test_tracer() {
+ local -x COVERAGE_CORE=${1}
+ einfo " Testing with the ${COVERAGE_CORE} core ..."
+ epytest -p flaky -p hypothesis -p xdist tests
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO: fails because of additional "Terminated" print on SIGTERM
+ tests/test_concurrency.py::SigtermTest::test_sigterm_threading_saves_data
+ # broken because of pytest plugins explicity loaded
+ tests/test_debug.py::ShortStackTest::test_short_stack{,_skip}
+ # these expect specific availability of C extension matching
+ # COVERAGE_CORE (which breaks testing pytracer on CPython)
+ tests/test_cmdline.py::CmdLineStdoutTest::test_version
+ tests/test_debug.py::DebugTraceTest::test_debug_sys_ctracer
+ )
+ local EPYTEST_IGNORE=(
+ # pip these days insists on fetching build deps from Internet
+ tests/test_venv.py
+ )
+
+ "${EPYTHON}" igor.py zip_mods || die
+
+ local -x COVERAGE_TESTING=True
+ # TODO: figure out why they can't be imported inside test env
+ local -x COVERAGE_NO_CONTRACTS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ local prev_opt=$(shopt -p nullglob)
+ shopt -s nullglob
+ local c_ext=( "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so )
+ ${prev_opt}
+
+ if [[ -n ${c_ext} ]]; then
+ cp "${c_ext}" coverage/ || die
+ test_tracer ctrace
+ fi
+
+ test_tracer pytrace
+
+ case ${EPYTHON} in
+ python3.1[01]|pypy3)
+ ;;
+ *)
+ # available since Python 3.12
+ test_tracer sysmon
+ ;;
+ esac
+
+ if [[ -n ${c_ext} ]]; then
+ rm coverage/*.so || die
+ fi
+}
diff --git a/dev-python/pyarrow/Manifest b/dev-python/pyarrow/Manifest
index 5b5e4b7adc6e..1fc637ff9725 100644
--- a/dev-python/pyarrow/Manifest
+++ b/dev-python/pyarrow/Manifest
@@ -1,3 +1,5 @@
DIST apache-arrow-14.0.1.tar.gz 20968461 BLAKE2B 01a4269f98ba2a4de1d6bc29f43a4e97132f8b7bdb3c3d022e0c0ba498527003e8bec0ea0b054f19ae54749f45fe39675f651f6c9e34e815df5a9b9926512431 SHA512 31d19f0ca80349f63db74bae813256b47907f85725a9bf01ef6f32406e79828ebb4701faedb52696b6a5b3bb89ad4e136485fd5eb35d396dd42147c11d4d2713
+DIST apache-arrow-14.0.2.tar.gz 20969982 BLAKE2B 9df119fca564a4140d1143a1ac0614831e4f80846d43439d011b8ca7f5e77461005c96b9430b6dd7ce0ba7496b879a8abc9ffa372e6b455c317abeebb16ae8e4 SHA512 dd6cf6cbb817a48ef5275bb409367e5904526a3c16a17a37ea75101085ea19a71ba6bf936a6f099012e7c528811db1728ef2f14dcb16a1056a22088839280ce0
EBUILD pyarrow-14.0.1.ebuild 1732 BLAKE2B fa80196f4222a802aa56c8d2defb12087e1927df55254adc879689cab866db380b49bd0d463f112d1666934f050ee0235ba8f316d51b43ea1b8d1c08eab6e976 SHA512 868ff4350e4810b59c4ac8f96ea745c738848d1aa47bbd6c4cbfed6b8f0aecd2454e1b8918209a9e080bdf9b49a8dab73faecd7470d624197ecfc55832b5427c
+EBUILD pyarrow-14.0.2.ebuild 1729 BLAKE2B 150cd20ca75cb4d954a2d3f966fd1499e08bee048e3d8d24de45b69838ba0d5bfec462bca509c3998409eece693d28957e12c0565bab23fc1331777aa5d03e4b SHA512 d53f7e263db782aaf78bf3afdecf9ce27ceb81be0cc623b12cf96a3023e332555b5e73066de2377ac23f99b01765196168bca18689515d953d78574c55828813
MISC metadata.xml 454 BLAKE2B aef32100cb88b74361bc57c83179ce223bab58fd2d33c0274011350f1021f8f738008a64b74995d005f9b53edf45d9e0168a38101e041297d38805529b7af416 SHA512 2b7d53db25c36faca27aa8885479396ad2b510d8fba9b421d969fd23505b5026b48a9869ab941fa8d09c2a399ed6f211d8694bc3ed05dc5bf583d7be1fc0e679
diff --git a/dev-python/pyarrow/pyarrow-14.0.2.ebuild b/dev-python/pyarrow/pyarrow-14.0.2.ebuild
new file mode 100644
index 000000000000..c0f420a92293
--- /dev/null
+++ b/dev-python/pyarrow/pyarrow-14.0.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Python library for Apache Arrow"
+HOMEPAGE="
+ https://pypi.org/project/pyarrow/
+ https://arrow.apache.org/
+"
+SRC_URI="mirror://apache/arrow/arrow-${PV}/apache-arrow-${PV}.tar.gz"
+S="${WORKDIR}/apache-arrow-${PV}/python"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="parquet snappy ssl"
+
+RDEPEND="
+ ~dev-libs/apache-arrow-${PV}[compute,dataset,json,parquet?,re2,snappy?,ssl?]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ dev-libs/apache-arrow[lz4,zlib]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # wtf?
+ tests/test_fs.py::test_localfs_errors
+ # these require apache-arrow with jemalloc that doesn't seem
+ # to be supported by the Gentoo package
+ tests/test_memory.py::test_env_var
+ tests/test_memory.py::test_specific_memory_pools
+ tests/test_memory.py::test_supported_memory_backends
+)
+
+src_compile() {
+ export PYARROW_PARALLEL="$(makeopts_jobs)"
+ export PYARROW_BUILD_VERBOSE=1
+ export PYARROW_CXXFLAGS="${CXXFLAGS}"
+ export PYARROW_BUNDLE_ARROW_CPP_HEADERS=0
+ export PYARROW_CMAKE_GENERATOR=Ninja
+ export PYARROW_WITH_HDFS=1
+ if use parquet; then
+ export PYARROW_WITH_DATASET=1
+ export PYARROW_WITH_PARQUET=1
+ use ssl && export PYARROW_WITH_PARQUET_ENCRYPTION=1
+ fi
+ if use snappy; then
+ export PYARROW_WITH_SNAPPY=1
+ fi
+
+ distutils-r1_src_compile
+}
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs pyarrow
+}