summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
commit7b830374520118e805fdd214530a389653750f51 (patch)
tree1f6ef2872a3f89b278b2d5c7f82f36df335dce30 /dev-python
parent3c490942d0d98701d1c0971e60911fa6bd3ecb76 (diff)
gentoo auto-resync : 16:09:2023 - 17:00:58
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin268132 -> 267957 bytes
-rw-r--r--dev-python/contourpy/Manifest2
-rw-r--r--dev-python/contourpy/contourpy-1.1.1.ebuild47
-rw-r--r--dev-python/dask/Manifest2
-rw-r--r--dev-python/dask/dask-2023.9.2.ebuild85
-rw-r--r--dev-python/pyGPG/Manifest6
-rw-r--r--dev-python/pyGPG/metadata.xml16
-rw-r--r--dev-python/pyGPG/pyGPG-0.2-r1.ebuild39
-rw-r--r--dev-python/pyGPG/pyGPG-0.2_p20220808.ebuild55
-rw-r--r--dev-python/pyGPG/pyGPG-9999.ebuild55
-rw-r--r--dev-python/python-lsp-server/Manifest2
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.8.0-r1.ebuild (renamed from dev-python/python-lsp-server/python-lsp-server-1.8.0.ebuild)2
-rw-r--r--dev-python/tcolorpy/Manifest2
-rw-r--r--dev-python/tcolorpy/tcolorpy-0.1.4.ebuild21
14 files changed, 161 insertions, 173 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index e214d5cd438e..ca8fda81358e 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/contourpy/Manifest b/dev-python/contourpy/Manifest
index 7885b1880363..c6d7c17afc7b 100644
--- a/dev-python/contourpy/Manifest
+++ b/dev-python/contourpy/Manifest
@@ -1,3 +1,5 @@
DIST contourpy-1.1.0.gh.tar.gz 13413711 BLAKE2B 020bf7f63dbe304e71b66249cdfa86047598a3f8352657f7c179bc068869bf7659fb7c821749a0be33a8a04ec02dc642ac7a9ed14f5fd73d4a1e9f20c3606ee2 SHA512 aeb60db039aa14aed29a31dcf6091708daf7e65589964dd7682dc28e085d584103abb872e607685408eaefd4947adeba966c9a0d93cb1f827805189e498c67d8
+DIST contourpy-1.1.1.gh.tar.gz 13417093 BLAKE2B 217b99a1000575d362ca60327f39d39fd5f241f1e0f94ac3f049e2bf195388424f10bfd33c2a007da32eb939c1a04e96942ce0092c091533166c54da906b68af SHA512 7d135f18fa28ecd5d6c715650fc5672291c6f46e96cfcf8d2571c401d5bae0d27fa6a2e9f80e4f735af3016c7ced92552f26e8c5519e725e1bf6fe54c7603a03
EBUILD contourpy-1.1.0.ebuild 1024 BLAKE2B 3cd165023b3eea552cc48bcb75029a5845c5d0093ce973eb29c263e89007d139e86753bc271c5862be043438f831e8c8d479481217ffb9b04fdae80153a7e3a5 SHA512 45ca7414f8f6f9b31f97a938dee3611520cde61c6d6905ecb62e38a42d5817692089b1463e88178a7f5a19e382cfca62ff31259b280bc1da30662b62623bb3e2
+EBUILD contourpy-1.1.1.ebuild 1032 BLAKE2B 5c697b8e3ea218432d57b588b6684241101c0130b74d47dba0beec8708c7c3d9e5ca2adfe7c19172cc4cf4a3f8b2ff09a33c6e5b7c6ba68a21cb2aacdab0a0c2 SHA512 3ef407c47dae128ad81ec0b4e06371f1b42622fd3f60bb0b2a5bcf614a1f892d99d50278c2e6880838be4dab1234bc30111f4b6f6a2be3412504bd14772a6aeb
MISC metadata.xml 372 BLAKE2B de3d6cc9d8727bf43be63fdbb8aa2ad375667d189019e189be262e39d028acab98a21e200798c2d5c5c72521aa7d38202e3e235dd44de9b43a7dc9e045d50c47 SHA512 e692f94d805d7f56fc895a4c76dfbacf2f068d687b9191482b946445baa3bd0a685eda7a1b0aec2aaf9a02e6f23d87f0bf22d90f42e3c21d930724c635ff859a
diff --git a/dev-python/contourpy/contourpy-1.1.1.ebuild b/dev-python/contourpy/contourpy-1.1.1.ebuild
new file mode 100644
index 000000000000..35481e118590
--- /dev/null
+++ b/dev-python/contourpy/contourpy-1.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
+HOMEPAGE="
+ https://pypi.org/project/contourpy/
+ https://github.com/contourpy/contourpy/
+"
+SRC_URI="
+ https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wurlitzer[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # linters
+ tests/test_codebase.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 48aadfcb5c2a..d3cda060bbcb 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -2,8 +2,10 @@ DIST dask-2023.8.0.gh.tar.gz 8539262 BLAKE2B 3ce61191bca458e32ac88904460f8ee843f
DIST dask-2023.8.1.gh.tar.gz 8541743 BLAKE2B 485a88354d3aa54ff1f6afb1bd4a8b3317a6a48b519bef4dadf1bcbb240f21e54eb165f2c076ea8aa9b5753fd8714af26453858d7fe154bb015489f89b8114be SHA512 4ca231236e5d868f8fbb69b38721e495a44fbc982a53ea087ef68085c4df2cc99526b5a66b7fee93a3b63a6cd621f8448b877b98370b3dfe1a32e386dd91e73e
DIST dask-2023.9.0.gh.tar.gz 8541973 BLAKE2B 06e04377f8f7d0e6a6487c1c2aa52e61a8ab73a04455e9a6d7da238bd747d7ac6cf1526f645f0c874f2588f28708139f8fb1fa0271e6166442be6a15ce68b9f1 SHA512 eadc3a9cd5d8d960d8006db2641e5513a093b4818c1cd4de058d70f088ef1cfd74413abcf0bbba757d9188de4b3c103a3fdfe4ce76f14554b589540011c53835
DIST dask-2023.9.1.gh.tar.gz 8544717 BLAKE2B 786ca3bda6b356acdeb56070964aa25e136f9976322ae5dbaf5895eb181fc1b7582ae4731de12e7881287433d4f502dbbc5002840ebc443403a9fa76df438693 SHA512 1bf0a028059dfba70a131648f4884a6c9a091cd2d550dc7968cb2a8728ce5ef405c351f100001ab2ce48470634577104924fdf4b6dadda32308b4b5a62b3200e
+DIST dask-2023.9.2.gh.tar.gz 8544631 BLAKE2B bd0168d1ea86921235e7bd9ae3e6b9dc2abed3c3e300afea84fb3f2d462970ca5fa4d82f5479bc2c036d4f1a1ec9f63ff98151d8f339db2b14533be765b0f25f SHA512 ae7d289882d7e2e2ef46af3256cf69d8e443f5350f32088e33b46f37377fe8c8328de609d16d0a2abf4df5bc7671d88288968d3d18a535eaec1bfbf0a5adbcba
EBUILD dask-2023.8.0.ebuild 2634 BLAKE2B f34d0f231c2a4b8e56b0f6bfb5c6de73c86b7ee99057d138db13d146b6dd73743a9df05fc27d52e7b4c9d894ed173cfe952075b744bab0d82186ce5aeda60721 SHA512 d88db20fbe8f8dd85879c385dce2ecef5796f6be883eb158be3481ebf82c88d0ca46ce6a1b7894842f75ddcdd6f5028cf88a2c0d8a365680294c2fb30c7717a1
EBUILD dask-2023.8.1.ebuild 2690 BLAKE2B 0fb80034035c15515794ce8e2fc146b179d593ad7acf03d63d464ac757452c0163d4ef65b2c6fbe5197446f3e5a8ff9a9274025887d9d0ff54323803fcd625f3 SHA512 99bfb1009e403d4aa5530c6353216757b391efc23692d20b3c285856a0812ee185b1c57ba13ebe32616fbfc791a9c6916daa9661e556350d04b52b1ee135f708
EBUILD dask-2023.9.0.ebuild 2690 BLAKE2B 0fb80034035c15515794ce8e2fc146b179d593ad7acf03d63d464ac757452c0163d4ef65b2c6fbe5197446f3e5a8ff9a9274025887d9d0ff54323803fcd625f3 SHA512 99bfb1009e403d4aa5530c6353216757b391efc23692d20b3c285856a0812ee185b1c57ba13ebe32616fbfc791a9c6916daa9661e556350d04b52b1ee135f708
EBUILD dask-2023.9.1.ebuild 2745 BLAKE2B 16fc9fa5481e2d5a6578bd1e413a9f2d9325a70bdcb3cf27a67bf04a125b8f25c408caa7c8b03886c6da7df85a472918035caac495ac8a097fa9435bcec07836 SHA512 d41be063c2a4389045d5ae61ae82b43964791ae142232aad716e7938900670afa21a1a425721682e3799a6a308653838777452bedad150c2ce997b7c1217a977
+EBUILD dask-2023.9.2.ebuild 2745 BLAKE2B 16fc9fa5481e2d5a6578bd1e413a9f2d9325a70bdcb3cf27a67bf04a125b8f25c408caa7c8b03886c6da7df85a472918035caac495ac8a097fa9435bcec07836 SHA512 d41be063c2a4389045d5ae61ae82b43964791ae142232aad716e7938900670afa21a1a425721682e3799a6a308653838777452bedad150c2ce997b7c1217a977
MISC metadata.xml 724 BLAKE2B 9af7553cec2b66228a21f146372d86b8d620048d68f94c1fd09006c8ee7ddaa4e212c2a359b937a5ee37ac23df01e10af0796e8b4cf952237cb4c73a2dff7ca0 SHA512 89b83402c13b06f7adf10cd1cc08b96b90dbc2ca3b5c0c6c422b6e2394e03fd51346306479557c11fcfdbd4a81a574890f2367228ea38531b5f05c02a30b8dcb
diff --git a/dev-python/dask/dask-2023.9.2.ebuild b/dev-python/dask/dask-2023.9.2.ebuild
new file mode 100644
index 000000000000..7e6a97864b43
--- /dev/null
+++ b/dev-python/dask/dask-2023.9.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://www.dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/cloudpickle-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.9.0[${PYTHON_USEDEP}]
+ >=dev-python/importlib-metadata-4.13.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.21[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-1.2.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/versioneer-0.28[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # fails with sqlalchemy-2.0, even though we don't use it x_x
+ sed -i -e '/RemovedIn20Warning/d' pyproject.toml || die
+ sed -i -e 's:--cov-config=pyproject.toml::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # more tests relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ dask/array/tests/test_random.py::test_RandomState_only_funcs
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+ dask/array/tests/test_linalg.py::test_solve_assume_a
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
+ dask/array/tests/test_image.py::test_preprocess
+ dask/tests/test_system.py::test_cpu_count_cgroups_v2
+ # require sqlalchemy<2.0
+ dask/dataframe/io/tests/test_sql.py
+ )
+
+ if ! has_version -b "dev-python/pyarrow[parquet,${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ # fails if pyarrow is installed without USE=parquet
+ # (optional dep, skipped if it's not installed at all)
+ dask/dataframe/io/tests/test_parquet.py::test_pyarrow_filter_divisions
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_rerunfailures -m "not network"
+}
diff --git a/dev-python/pyGPG/Manifest b/dev-python/pyGPG/Manifest
deleted file mode 100644
index 7688954c1fc2..000000000000
--- a/dev-python/pyGPG/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-DIST pyGPG-0.2.tar.gz 15439 BLAKE2B 92c82b8b23c279461a872f118c636fa9cdae3f44910fc34a357983b0b4afea2a7b13c6400499a0fdbb4365357ade64294642178ca07a79ab3b7df89e60146e73 SHA512 93d892a57a27b254bfdc9778b73d341dfec654c2104c578014628df78c43beaf93eafb571ac544d52f334e63f6e5b8c0cfad7c8a0d585ee7211e8649efce8c67
-DIST pyGPG-0.2_p20220808.gh.tar.gz 31955 BLAKE2B ae671b7bf685b1072364dbfcf79bca8fa2dadd034fbdf7a721d7a2cfec44e8d8ffa22b08c14414c8774422b6a62af8d511bd31bd15bd68d89632cde031ec0906 SHA512 85c8d67e71e91cfb26b1e0087889d7cd4fccae9ddcffcd3e3f9d208da7fd352c3273c580e3b7c284c5ab4c2a53c56f4530e5587dc22869098a408a1dfcd1e257
-EBUILD pyGPG-0.2-r1.ebuild 1112 BLAKE2B dca46b2d5c8e440eb6df37f6c113af181185d9b0e8474301ffe6bb05b09c3d67299ac63ba7b22f1511f8c5538c2b5889d044928a51d2d1de829e910a6ec7f50b SHA512 8870481c0e65f4bf0cd9130134fb8a432cff247e1e3217e2574e3ffaff371ff8331b2733f90dcf5c3afbcab5ceda9c2ae9550595d6361416a4bb72f63ce5afa4
-EBUILD pyGPG-0.2_p20220808.ebuild 1587 BLAKE2B f6170ddefa618cc78e9057d06846b12ef449bbb2e555cae6b704b716fec9a3b3dd515883be6a2ff1c9c18f00dde390614bc29dc69ab446f1d8f93d553b5eb839 SHA512 04aa3c2642d2c2bbf2acf1dcb4e8789d200652845fbf73684888d869f0221e83ea215631f2ee87a2ecf71bd81f6152531560e67f22e0c0ba0e8138ceefb5c64d
-EBUILD pyGPG-9999.ebuild 1594 BLAKE2B c12bb0c6ea350e5deb24ddca51d0ba9e5201fbb626a49aafdae399a68395199092ebf1cc73c01a06dc18ba0e401454f48e2c5bc2f172d5a6e60dfc6cd80bfe0b SHA512 19881e78c5a585672ee54a916458c4d824a63d1e52ece5226ea2a94487ca009b789b046942a86db9a038254d16d1266593f033a11f0307eee1d0901390523c7a
-MISC metadata.xml 591 BLAKE2B d2187a3f5cdcd550d716834307a9d79bdefda8d019b31d46615e01cf921ede9b03a5f5a5c2e8cf954ac8bb76913206d227b5f817409af80b1868e2cc40f3e00b SHA512 28bfa15f105fa5a5067764e790ff954e4c3cd53bfcb794a5586c9101dae09d7f89398f109747bb5537e740c845a0bd1368395cfd6fe8835b0ba7f163a8187206
diff --git a/dev-python/pyGPG/metadata.xml b/dev-python/pyGPG/metadata.xml
deleted file mode 100644
index b04f3dcc2151..000000000000
--- a/dev-python/pyGPG/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>tools-portage@gentoo.org</email>
- <name>Gentoo Portage tools team</name>
- </maintainer>
- <longdescription>A python interface library for wrapping gnupg's gpg command.
- It also connects to gpg's status-fd output and makes all the status data
- available as subclassed namedtuple instances.
- </longdescription>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="github">dol-sen/pyGPG</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pyGPG/pyGPG-0.2-r1.ebuild b/dev-python/pyGPG/pyGPG-0.2-r1.ebuild
deleted file mode 100644
index 43eeb1b5b61b..000000000000
--- a/dev-python/pyGPG/pyGPG-0.2-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9,10} )
-
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
- EGIT_BRANCH="master"
-else
- SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-DESCRIPTION="A python interface wrapper for gnupg's gpg command"
-HOMEPAGE="https://github.com/dol-sen/pyGPG"
-
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND="app-crypt/gnupg"
-
-pkg_postinst() {
- elog "This is experimental software."
- elog "The APIs it installs should be considered unstable"
- elog "and are subject to change."
- elog
- elog "Please file any enhancement requests, or bugs"
- elog "at https://github.com/dol-sen/pyGPG/issues"
- elog "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
- elog
- ewarn "There may be some Python 3 compatibility issues still."
- ewarn "Please help debug/fix/report them in github or bugzilla."
-}
diff --git a/dev-python/pyGPG/pyGPG-0.2_p20220808.ebuild b/dev-python/pyGPG/pyGPG-0.2_p20220808.ebuild
deleted file mode 100644
index 78f1b9b5f5db..000000000000
--- a/dev-python/pyGPG/pyGPG-0.2_p20220808.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
- EGIT_BRANCH="master"
-elif [[ ${PV} == *_p* ]] ; then
- MY_COMMIT="eb44ec69978044809325a0a9c8972d1d4f573b47"
- SRC_URI="https://github.com/dol-sen/pyGPG/archive/${MY_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
- S="${WORKDIR}"/${PN}-${MY_COMMIT}
-else
- SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
-fi
-
-DESCRIPTION="A python interface wrapper for gnupg's gpg command"
-HOMEPAGE="https://github.com/dol-sen/pyGPG"
-
-LICENSE="BSD"
-SLOT="0"
-if [[ ${PV} != *9999 ]] ; then
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-RDEPEND="app-crypt/gnupg"
-
-EPYTEST_DESELECT=(
- # Expired keys
- test/pyGPG/test_gpg.py::test_listkeys2
- test/pyGPG/test_gpg.py::test_listkey2
- test/pyGPG/test_gpg.py::test_listkey
- test/pyGPG/test_gpg.py::test_fingerprint2
-)
-
-distutils_enable_tests pytest
-
-pkg_postinst() {
- elog "This is experimental software."
- elog "The APIs it installs should be considered unstable"
- elog "and are subject to change."
- elog
- elog "Please file any enhancement requests, or bugs"
- elog "at https://github.com/dol-sen/pyGPG/issues"
- elog "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
- elog
- ewarn "There may be some Python 3 compatibility issues still."
- ewarn "Please help debug/fix/report them in github or bugzilla."
-}
diff --git a/dev-python/pyGPG/pyGPG-9999.ebuild b/dev-python/pyGPG/pyGPG-9999.ebuild
deleted file mode 100644
index 6749e63d1904..000000000000
--- a/dev-python/pyGPG/pyGPG-9999.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
- EGIT_BRANCH="master"
-elif [[ ${PV} == *_p* ]] ; then
- MY_COMMIT="eb44ec69978044809325a0a9c8972d1d4f573b47"
- SRC_URI="https://github.com/dol-sen/pyGPG/archive/${MY_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
- S="${WORKDIR}"/${PN}-${MY_COMMIT}
-else
- SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
-fi
-
-DESCRIPTION="A python interface wrapper for gnupg's gpg command"
-HOMEPAGE="https://github.com/dol-sen/pyGPG"
-
-LICENSE="BSD"
-SLOT="0"
-if [[ ${PV} != *9999 ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-RDEPEND="app-crypt/gnupg"
-
-EPYTEST_DESELECT=(
- # Expired keys
- test/pyGPG/test_gpg.py::test_listkeys2
- test/pyGPG/test_gpg.py::test_listkey2
- test/pyGPG/test_gpg.py::test_listkey
- test/pyGPG/test_gpg.py::test_fingerprint2
-)
-
-distutils_enable_tests pytest
-
-pkg_postinst() {
- elog "This is experimental software."
- elog "The APIs it installs should be considered unstable"
- elog "and are subject to change."
- elog
- elog "Please file any enhancement requests, or bugs"
- elog "at https://github.com/dol-sen/pyGPG/issues"
- elog "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
- elog
- ewarn "There may be some Python 3 compatibility issues still."
- ewarn "Please help debug/fix/report them in github or bugzilla."
-}
diff --git a/dev-python/python-lsp-server/Manifest b/dev-python/python-lsp-server/Manifest
index 62fbdeae03e0..e0f37d87b88b 100644
--- a/dev-python/python-lsp-server/Manifest
+++ b/dev-python/python-lsp-server/Manifest
@@ -1,5 +1,5 @@
DIST python-lsp-server-1.7.4.tar.gz 97864 BLAKE2B 9832298391d72bf2f035f388694a7879d66546ead5a36837220cb3af5d8181eba198c04dd82747cba75f0478d256b001476c24b02bc679fc07cb41c7aedb0e66 SHA512 7aa96de6e51548e2854b55690698fe6c7bda60103c11ad5982df611c65569cec1ab13691727c92ec47d9ac44c34f233f872211a41041ea0969223e10e87d7e08
DIST python-lsp-server-1.8.0.tar.gz 105548 BLAKE2B aa7f714bbc7e88d68224f9a51c3c811168ade36afce02fcdf95d3ffef55f7efc964aea6fb3c26bc88c3439744928f70914c136987c89a8bd146a2f54df579ead SHA512 b8050037e313261b653f0df170762126886ceef780d7ca35651c79967270d78d9930e464ccecc71a40ceee10b0265fd262d200e1e38c50ce04490ab364bc8389
EBUILD python-lsp-server-1.7.4.ebuild 2926 BLAKE2B 3f7e5f4f6225f660e373754725b7a26f49a8f7e31b5726fed0e80178c11f67a52ef7f57eb0b6247c6813f0aff56ba6369e4a6c9e38d37aea1a26e3d5bfb61622 SHA512 30973ec2c9f0f0788000159ff40ab2152f1dcb37b3af9f02911ac0d4336fcf0542f6b86ffe82d9f057d63ba130f67f3b34ddada07259dd833f4b4a78d4fc0bd8
-EBUILD python-lsp-server-1.8.0.ebuild 3057 BLAKE2B 0d00f2c6c96329b39fa8eafc6f6601fbf884862bdaef411384d24900a496a9d18a5706fc1c7c5b4add0ef615278e76eb2283b584bf05052a81220b67dc297f9a SHA512 121d84cc2ac8b23e66d4e32cfd5844c8a2744b243f8db83a23f611443ff08903a34e319f0019846636a16c25b3b303321c318fe4d2b02482acf6de62f2d5c0a0
+EBUILD python-lsp-server-1.8.0-r1.ebuild 3057 BLAKE2B 9ffa856cdae89cbd7edd322779bd36526351b4f4effe5fbe627d26e8ba031b7e76e59ac5186128d4c76ce364ec4bfeda551c48b7588ae92799dfb0dbd50a4e11 SHA512 add354d00079b5cd1dbca1e5119eec3679fae8df56bbbf1b9f40becf941e868cb2c2f29cd889fed8e0c5e343bb726fd583b994c644ae1ed670aa72eddfd91cbb
MISC metadata.xml 610 BLAKE2B e111007adc2612409df72955babe0c4725fd5726449435988cf13c1142049d78089d38e54783712e2c70c74437157ffb2049bd9d63322cec084204eb5038e724 SHA512 5e1e4b43a5bfacb6a2fcae57413ebf79c6aed917b00022140d855acd773d82e56b2d73ae8270d42675a34d9f37f9ad53c8f61930c3f447d8a9e45a521a20e9bb
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.8.0.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.8.0-r1.ebuild
index a201af3d084e..eb9ed7fff1e0 100644
--- a/dev-python/python-lsp-server/python-lsp-server-1.8.0.ebuild
+++ b/dev-python/python-lsp-server/python-lsp-server-1.8.0-r1.ebuild
@@ -23,7 +23,7 @@ IUSE="all-plugins"
RDEPEND="
dev-python/docstring-to-markdown[${PYTHON_USEDEP}]
>=dev-python/jedi-0.17.2[${PYTHON_USEDEP}]
- >=dev-python/python-lsp-jsonrpc-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-lsp-jsonrpc-1.1.0[${PYTHON_USEDEP}]
dev-python/pluggy[${PYTHON_USEDEP}]
all-plugins? (
>=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
diff --git a/dev-python/tcolorpy/Manifest b/dev-python/tcolorpy/Manifest
index bd988681f58c..91065be9c51b 100644
--- a/dev-python/tcolorpy/Manifest
+++ b/dev-python/tcolorpy/Manifest
@@ -1,3 +1,5 @@
DIST tcolorpy-0.1.3.tar.gz 10880 BLAKE2B acae626ccc330b5eb0032d9e14d157bd1fbc588dc72c72ff700980ee9a572a4296700026ba26623857ae7bd43febe109c66b8e4d9eb0a82146d7eab90234207e SHA512 978360b224959f8d050fc889a329a191102cf42fb60c1ca298cd0ab53a6c75a4181ef7ded7282d05614cb415b56f141086e9efc6c9c32922aa9ccd3e101e9a1e
+DIST tcolorpy-0.1.4.tar.gz 11072 BLAKE2B 2ceefe31475d44546efbf919c6353caf3d023f269f1cf373185900704c88d318bd7c96beae2e0ef287a695ef1cf7367fd5e5dd21d73a61400b17a9a40d1d727a SHA512 4be98b0819c6eca0af55170e473e26b90d0c62b81c00fb1fe66b197f1fd6e7aec38cdd2b24dcc1b059af0ed1a54cfdc0900fad2e9145bf49b578d90edc65e74c
EBUILD tcolorpy-0.1.3.ebuild 416 BLAKE2B 84600960b9ea6d501718c605681654f344694e2881c34509a23b147b1632e5b7cf57f7ce11c95173cebbde9e7b35d46ed5fcd967c3586323c089c0199d90058e SHA512 118ff99c097af080b1dd95414a5cd74ee08a3f83d4699a9cca2a258314b56856decc18584bf557662b1ef8d34d1d91937b3a6f6d77ffa5d6505c7d0431caf84b
+EBUILD tcolorpy-0.1.4.ebuild 455 BLAKE2B 3f1306f1f234de9f5bd83b4582327b01c69043e969523af590086336040d7130b656db0b1184f8ff92a7a5af6538c7d42b99d7525afca5bea2ce159606018178 SHA512 688c47ae2d470146e10c4217b964265e07e874749b6b4f59484f9517daa864029c795949a3c4d866123e6b2b426b58aa83099eb835703d9c7819993799f000a2
MISC metadata.xml 372 BLAKE2B 83814ee2a7eb02f03e516b528f52d482d8ebf6d95923c03cf527a797f66f71a22de1f498578e1288251cf461d1b0f81f1c069a734e4b09dbd3b87ad82a5c7cb5 SHA512 ab4767ee7d098a9d99ad8a806b2079ddced2dbb650d5e9b5cc1762cb20ffadba4807524a05ae19acc3a469601420562ce1b31cccf966550869d4fd79360a7689
diff --git a/dev-python/tcolorpy/tcolorpy-0.1.4.ebuild b/dev-python/tcolorpy/tcolorpy-0.1.4.ebuild
new file mode 100644
index 000000000000..266ec31cb08c
--- /dev/null
+++ b/dev-python/tcolorpy/tcolorpy-0.1.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="tcolorpy is a Python library to apply true color for terminal text"
+HOMEPAGE="
+ https://github.com/thombashi/tcolorpy/
+ https://pypi.org/project/colorpy/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest