summaryrefslogtreecommitdiff
path: root/dev-qt/assistant
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-qt/assistant
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-qt/assistant')
-rw-r--r--dev-qt/assistant/Manifest3
-rw-r--r--dev-qt/assistant/assistant-5.15.3.ebuild60
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-qt/assistant/Manifest b/dev-qt/assistant/Manifest
index 445713de5f6c..5c62191bc702 100644
--- a/dev-qt/assistant/Manifest
+++ b/dev-qt/assistant/Manifest
@@ -1,3 +1,6 @@
DIST qttools-5.15.2-33693a92.tar.gz 12266718 BLAKE2B c519abdcca9df3b191297b859b2dce417ee9a79f9e3bcb3f2aa0017266b8edc855645108f5f7e6853d28f4c7507c92646ce8130731a345c6ffdfcd37fb1f4789 SHA512 9a62f1849c8eb65384d19de61cb6a08d1f467877181fd752e58b2b4e7d566c5d868c7ebab2d01591c6f540c01c705b7f8e0fe76c26cb0ee78f590ddae57048d2
+DIST qttools-5.15.3-gentoo-kde-1.tar.xz 1472 BLAKE2B eb4f5555127b91767a06c126795930a8331b8431e77dc6c689098dd0249dc324bec37f2f7e816505cc41fd9578d62110a41d2d064b3ca509a56600f967c31690 SHA512 5572b228cd80df8d49627bba4078943eed3e284de53336608ef7c2db36d6f9fd03be0f6060ccce79c59ab439650125fd59ad7d8ae16a2aeeebe4702f7b7f9354
+DIST qttools-everywhere-opensource-src-5.15.3.tar.xz 8896764 BLAKE2B 65a5d67a5f1c00c244ed91baf24ca10cd2e371963c4f55b3837701d71859b7adc03897db2021040eb08b85eb0f5d353bc8b9d7944aecbeec64397f7e0c20735f SHA512 3c4ffee1d67126e3dd10c1dabae3660b94b97541480814b77bc88c0eaf86d8d43324d582465521fbdbd49dbb4155561f93e91c998dc1ad6553da02a3fcb0da47
EBUILD assistant-5.15.2-r11.ebuild 1268 BLAKE2B 544f6db99e16de4974069f3dae1587da31357870d86244c186ac498e55360a752740944a8fc8ddf4abeef94d8be74954cc918b54e78f4f0c1d33daf44f8498b4 SHA512 282e2a2d22fb092567909e25b754150213cc637c37dd632fd56d9634fe3ad4c483b3f90bd608721c647a32a7d98a4c96485807bcf8175b34a9eb0e6ce911e036
+EBUILD assistant-5.15.3.ebuild 1320 BLAKE2B 80031f2010d12e3cfa76dc6d6a7f9d055dba562e204c22a0d6db0881cf277a6a6464d1f28722fd6a5645239d4d2f30b0d3a5c8ff023d46ef769a0add73ddc3c2 SHA512 e3d7862b8dcb27c3f16bcf745fea4f8e2dc679e768bfb307b823327cf04c4619bfcd17fb1fb69935cc4fada7f3ace79a6534fc6b221b3d3ed0d921e2c32ae689
MISC metadata.xml 482 BLAKE2B 651a49dc4a07f5e5a9c21990868e666d98acdea7d7b0b2c0e4c98eafc3da72c803d380e4abda30f33250f7bbd7654df713833ccdddcb975cbad6f92e488f643b SHA512 192c670abd7da29645513bf1d9297d942efdc49f5cf170861e7689fda47f51daa47f10c7c81c3b045366e0259179c6839ff7747197c9d792e8d0fd1a5818973e
diff --git a/dev-qt/assistant/assistant-5.15.3.ebuild b/dev-qt/assistant/assistant-5.15.3.ebuild
new file mode 100644
index 000000000000..d2e3b01cf0d9
--- /dev/null
+++ b/dev-qt/assistant/assistant-5.15.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_KDEPATCHSET_REV=1
+QT5_MODULE="qttools"
+inherit desktop qt5-build xdg-utils
+
+DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*[png]
+ =dev-qt/qthelp-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtprintsupport-${QT5_PV}*
+ =dev-qt/qtsql-${QT5_PV}*[sqlite]
+ =dev-qt/qtwidgets-${QT5_PV}*
+"
+RDEPEND="${DEPEND}
+ !dev-qt/${PN}:5
+ !<dev-qt/qtchooser-66-r2
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/assistant
+)
+
+src_prepare() {
+ sed -e "s/qtHaveModule(webkitwidgets)/false/g" \
+ -i src/assistant/assistant/assistant.pro || die
+
+ qt5-build_src_prepare
+}
+
+src_install() {
+ qt5-build_src_install
+ qt5_symlink_binary_to_path assistant
+
+ doicon -s 32 src/assistant/assistant/images/assistant.png
+ newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
+ make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ xdg_icon_cache_update
+}