summaryrefslogtreecommitdiff
path: root/dev-qt/assistant
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 18:03:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 18:03:40 +0100
commit418459f7de9eb29d6db8b61681f39c467d9600e1 (patch)
tree87b23e3d06e1b08b13c64e16503aa7ea88b38a8a /dev-qt/assistant
parent522fa4e6f267ba688a264ceec8d6c79663b61219 (diff)
gentoo auto-resync : 08:10:2023 - 18:03:40
Diffstat (limited to 'dev-qt/assistant')
-rw-r--r--dev-qt/assistant/Manifest3
-rw-r--r--dev-qt/assistant/assistant-5.15.11.ebuild60
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-qt/assistant/Manifest b/dev-qt/assistant/Manifest
index defe920e80c9..3e259903b034 100644
--- a/dev-qt/assistant/Manifest
+++ b/dev-qt/assistant/Manifest
@@ -1,4 +1,7 @@
DIST qttools-5.15.10-gentoo-kde-1.tar.xz 3188 BLAKE2B bc9b411398dc225f16a654d025ef69318988c80554c732ab0fdf19cedd8429775c6569f99f656fa27494c407eb319e7a4eb42fc201ef0f543380dcbdb2898559 SHA512 b95278acb13db8c2c05f2d1fcf1d07f3939135c6684ee078db1fa9fb88dfe435c5095faf567fb510be018ed6aa04c0c780359116f38ada41bf56151f4dc8fa97
+DIST qttools-5.15.11-gentoo-kde-1.tar.xz 3188 BLAKE2B 0ec418efb257f9d32e1a245bbdf9321e2070bae0e0b1d1306cde2a748cce1a0cc73a5631631c50b202320d8357fa132d645abbb7da42d38b5d212033aa74a5cd SHA512 eb03030070c3ef87b9a29f7a77f918514e4565f506fc5f39030ffb54aeec3b7fd87fae720595158527288cd152e0d179714159e03819f1cc4efa82650a7054fe
DIST qttools-everywhere-opensource-src-5.15.10.tar.xz 8899372 BLAKE2B c49cfc36640f68743f7c21f06ac87221b3e8b92a2fa096c54cf539bc4eb80a99decfb6f0fde53b1c5334612bf5d8641465f350143470429c505b6dc7f597bcf0 SHA512 08d5182309c0f19f14af4e509871bca13b89cdd762bd4b7f98b15120b2e74308e478f826b4236f01abc299520da32b716df9e7bfaa84935fbdc0a74422ade5f1
+DIST qttools-everywhere-opensource-src-5.15.11.tar.xz 8898428 BLAKE2B 88e3e313f2377819345c67cd9e6ff90ca96961662e0e24640a04eda37f46fb444f958c69fb3a5e279da679cd6a25f8b232038d13eb9023cfad79fbd9ea53ae56 SHA512 7aa66964dfc4bd144ee828a5c278b3127c5b269c6fb0e5363e7d2377ba19165e04719636659cb30fee471de26740d3d8692068459e1764d9f84a7737f24c4884
EBUILD assistant-5.15.10.ebuild 1304 BLAKE2B a8346fafdd8d94ad7da1f46ef1ba63bdff287c9a50b3fce4cb1eeeecb810b7e1117323bb503c83f54e7237f1d920d9d43f9e5ec4cde95e9403be0e1e3da69080 SHA512 b11a0b125b33f8760db75d31f65a46d7928502eda6bee6cd9a4b6518386fa753612a0a673d685a30ff87d1c8fc0b6ff37b99c33f47de48a7afdebfecdea5c5f3
+EBUILD assistant-5.15.11.ebuild 1308 BLAKE2B be0c02b5f2049c90f86f483b7c02e2c72921845fda5404645affe6929375abd43480b141f5c5756cf3d7ba551a7eca8f5b25b55f5117d02ef2c9bcc04414d327 SHA512 8eb82d0e9659f4e5c98a78f1776ec993d074496e61f99e39ee3291d8fa7d1d73d71f91287ff6a302b331511ba9552845c0ad610ebfddd1ae0aeebdc0b2f53e34
MISC metadata.xml 482 BLAKE2B 651a49dc4a07f5e5a9c21990868e666d98acdea7d7b0b2c0e4c98eafc3da72c803d380e4abda30f33250f7bbd7654df713833ccdddcb975cbad6f92e488f643b SHA512 192c670abd7da29645513bf1d9297d942efdc49f5cf170861e7689fda47f51daa47f10c7c81c3b045366e0259179c6839ff7747197c9d792e8d0fd1a5818973e
diff --git a/dev-qt/assistant/assistant-5.15.11.ebuild b/dev-qt/assistant/assistant-5.15.11.ebuild
new file mode 100644
index 000000000000..12f38d51e08a
--- /dev/null
+++ b/dev-qt/assistant/assistant-5.15.11.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+fi
+
+QT5_MODULE="qttools"
+inherit desktop qt5-build xdg-utils
+
+DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*[png]
+ =dev-qt/qthelp-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtprintsupport-${QT5_PV}*
+ =dev-qt/qtsql-${QT5_PV}*[sqlite]
+ =dev-qt/qtwidgets-${QT5_PV}*
+"
+RDEPEND="${DEPEND}
+ !dev-qt/${PN}:5
+ !<dev-qt/qtchooser-66-r2
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/assistant
+)
+
+src_prepare() {
+ sed -e "s/qtHaveModule(webkitwidgets)/false/g" \
+ -i src/assistant/assistant/assistant.pro || die
+
+ qt5-build_src_prepare
+}
+
+src_install() {
+ qt5-build_src_install
+ qt5_symlink_binary_to_path assistant
+
+ doicon -s 32 src/assistant/assistant/images/assistant.png
+ newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
+ make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ xdg_icon_cache_update
+}