summaryrefslogtreecommitdiff
path: root/dev-qt/qtimageformats
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-27 01:57:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-27 01:57:18 +0000
commit2db43213e5c343995f4b9fb977726fe42ebdac67 (patch)
tree6707366d284d46256ffc9490ab6d2940a83cd0ae /dev-qt/qtimageformats
parent236302aac694377916670b7769f941e3f1dd0bbc (diff)
gentoo auto-resync : 27:01:2023 - 01:57:17
Diffstat (limited to 'dev-qt/qtimageformats')
-rw-r--r--dev-qt/qtimageformats/Manifest1
-rw-r--r--dev-qt/qtimageformats/qtimageformats-5.15.8-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-qt/qtimageformats/Manifest b/dev-qt/qtimageformats/Manifest
index 72ddf5880643..26a4c5cda00f 100644
--- a/dev-qt/qtimageformats/Manifest
+++ b/dev-qt/qtimageformats/Manifest
@@ -2,6 +2,7 @@ DIST qtimageformats-5.15.8-gentoo-kde-1.tar.xz 5000 BLAKE2B 1d1a5054267bf8e28051
DIST qtimageformats-everywhere-opensource-src-5.15.8.tar.xz 1843016 BLAKE2B 55f4a0b212e63483d23a8a962ffafd826994088e00025291a502d371540e2d88217f5caeea03d40347ff756033b47ffa71e1e250673b977013b7dd5d190b0e7c SHA512 e601a1ebd0881e59c1f87df748faf63df12f552fe668d16af27a58421848ba4de822b4dc3fc54f23c17b818408b6af2edbfb0b59c29e7da8a272d25ac51d7cdd
DIST qtimageformats-everywhere-src-6.4.0.tar.xz 1861400 BLAKE2B be2d99999a29b5876981d0768d63dab6a70181a1643be73e83cb7bf6771bd35462165e1a848206d4f69018c3388118f4bd94a336ff28ab19dbc75973eb86463b SHA512 3a7302cfbe9187ffb753c7171c62bbf43223c9c876bb0df20de8b593d51ef775bffeff124d269ed8d4ce7e1fb3d55790acd75bce0b5d5bfa223e5e83dfb41f01
DIST qtimageformats-everywhere-src-6.4.2.tar.xz 1938812 BLAKE2B 65d1e5e7c415397cb411acc60fdb7ba316e986de30eb23a14c92f4fa6d3280bbb7aab2e592fd6d360052ba757472e8fd0aa35212fa3be545e07a4714bfe93ac7 SHA512 2bda0001295d1a27ee3018d7a7236525ee41f7de33d58805a71277b5a7d8f9506687a7bb9d6630e32cbcb89e340048591e9f9d29833a3bb4d8168c4779dc5320
+EBUILD qtimageformats-5.15.8-r1.ebuild 702 BLAKE2B 886af5f9b38be2bc82f5e81f121fba46687807ab77b34809158b767e592177466350a0f9110011e7998961132f6da54ca1dda0fabfda12ae0fea71b1d73137ae SHA512 3be583ce27469d7b5e5a21f75f05bf3e1acbc27bac6c12d86dfcb1fecd6046a0c6f2acf6b9b99e5a6092feeb400b598c4bf0ad1adebe789ee1b80350d5bdce3a
EBUILD qtimageformats-5.15.8.ebuild 698 BLAKE2B ad1a859438729b83988a8ca0a97b2e75b295f0f077a8cc93b2157f828238623e16d60fd4de835ce1b93851d55c4cfb308868ea76cd61ba5db04f733f11c61f76 SHA512 a74183f207d9008a88b0fc9140349c56f555d613ae6c12b9c0615c440ce982ad7739ae61bc079352a14f66198d00dc7d04abe5e5bf6dd4b358cc45ea71f8af43
EBUILD qtimageformats-6.4.0-r1.ebuild 633 BLAKE2B 1d17b7e376cdab0291450c0fce5da50f5ce7882670f3a6e02b4660ba2f6ffdfba8e4c8df51f15cd77ca8567e0fb01ab56af6f1772ec6d36a96cf5f20ffa0c227 SHA512 47d854a16b2af5c5fe487a8d4ca8052c49f3e5fbb4ffeccea85bec59d2926d640812e15aeab89d0ee807a8efa5c2e2aa85e1e089ed48568f827fb167ee8665d3
EBUILD qtimageformats-6.4.2.ebuild 633 BLAKE2B 11de4650840755a4b30608ebbcd7db6bcfa2cb18c9e5cbfa12768233fe307e8038e0647062fc4d3a3a30be75515268e300c1859e2a846280f177de5e9a8f7ef3 SHA512 e41c878b72d2fe1e1d38b37265c7aab66c7a183285053aec604541149e81d7300f20901cbfe9ab6537fec168adcc7a9e0bda809db0ed3ea96412bbfa835424f2
diff --git a/dev-qt/qtimageformats/qtimageformats-5.15.8-r1.ebuild b/dev-qt/qtimageformats/qtimageformats-5.15.8-r1.ebuild
new file mode 100644
index 000000000000..1fc71ebd4a6d
--- /dev/null
+++ b/dev-qt/qtimageformats/qtimageformats-5.15.8-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+inherit qt5-build
+
+DESCRIPTION="Additional format plugins for the Qt image I/O system"
+
+IUSE="mng"
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ media-libs/libwebp:=
+ media-libs/tiff:=
+ mng? ( media-libs/libmng:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ sed -e 's/qtConfig(jasper)/false:/' \
+ -i src/plugins/imageformats/imageformats.pro || die
+ qt_use_disable_config mng mng src/plugins/imageformats/imageformats.pro
+
+ qt5-build_src_configure
+}