summaryrefslogtreecommitdiff
path: root/dev-qt/qtlocation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
commit1c33e521c460dc40899ce7bc919602b842ce27e2 (patch)
tree580eefad4cce1e883e7504b93352a9029b53036d /dev-qt/qtlocation
parent65e4244e411c4f65f55f2aa91f39e228f4c0680b (diff)
gentoo auto-resync : 05:03:2023 - 23:52:45
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest3
-rw-r--r--dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-gcc13.patch51
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.8.ebuild2
3 files changed, 55 insertions, 1 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 77bbe98d71a5..fbc1d1a25a35 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,4 +1,5 @@
+AUX qtlocation-5.15.8-mapboxgl-gcc13.patch 1648 BLAKE2B 37b5282d514f0282223ed4914c65bff098d3de72355226c7f9338262acc1dfea4ec490a03efea1f7785bf9d61a9d5586d32ad2b027776e4bc07f186c9741c929 SHA512 c323a07beff23c005278d6dfc27de30610056279a31258c8c20d711d936700b6246ad9dcbdf255c7bd0110607b3c2351699c2495140eab95733b268bccba7220
DIST qtlocation-5.15.8-gentoo-kde-1.tar.xz 3952 BLAKE2B 6084d14533ca2ba44249db817f1f0bb93e526fc14e4f4f32d9c99f7b231e25449b111bf9e08b8dca95928d3ac29f63a8e42cbd51d9cd0700344aad6982dd2ff9 SHA512 868e96a2a84bfb0e068957968c07b3558bef2c12517c5971b11e1b536a92ae80d0ca399355f8fadc0fcef2b272b77e6b30951f96ec7fbe174bb5a053567d2c9e
DIST qtlocation-everywhere-opensource-src-5.15.8.tar.xz 6559180 BLAKE2B 1b8feb5da8d564a6605d9106ec6399aea23a4f0b43f495baf61e14266e90d2d73cd310fb6d8514730867acba1aa26efb3072c213f22f19f72c2f554d76ab281b SHA512 a337fade917150c13fa2ea22ad1949f41541cea4ceb1f732ab53c20c2f19a63dcfc6f9f544ca64fdb5703d3ac8d2ec6e832f1f199a32e73a2f6c51febf53f514
-EBUILD qtlocation-5.15.8.ebuild 1146 BLAKE2B 141a6df9553c0cd1d6531c52acc25c376a6081fc3499f8ca968f6edf502531e564f47b3be09ee6f55d3121c32e7b4f92077c286c7b58d45ed1cd239fc4d687dc SHA512 f269471f3a9100f3d059134573dfc88465896e6d2dba9c2b89f93a66428dfd1ea1c9fe005653f9d588ad7961d68f1091642e6a72a5ff639016068b8c39c6d31b
+EBUILD qtlocation-5.15.8.ebuild 1212 BLAKE2B 3a828dab652937f17dec7eb827f22737554f8b25503065c62422b3139ee9eb2cb8ac5ca2935c46f2f12d5ee0a1ea6e4a258b0e0916ce9b8bedc71180a8cbc182 SHA512 80ec32c6e6a161665dcf0cdbe9838dc12484979e428b1ed08c4d8fbcc57546bbff7dc882b03e1da1c6a2eddd9afbde03189a9419a1424e765f392fa082dd78ed
MISC metadata.xml 482 BLAKE2B 651a49dc4a07f5e5a9c21990868e666d98acdea7d7b0b2c0e4c98eafc3da72c803d380e4abda30f33250f7bbd7654df713833ccdddcb975cbad6f92e488f643b SHA512 192c670abd7da29645513bf1d9297d942efdc49f5cf170861e7689fda47f51daa47f10c7c81c3b045366e0259179c6839ff7747197c9d792e8d0fd1a5818973e
diff --git a/dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-gcc13.patch b/dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-gcc13.patch
new file mode 100644
index 000000000000..ba4e94e859fb
--- /dev/null
+++ b/dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-gcc13.patch
@@ -0,0 +1,51 @@
+From d8054f1efa0b97b291a6f8c7fff9090b0fd4328e Mon Sep 17 00:00:00 2001
+From: Fabian Vogt <fvogt@suse.de>
+Date: Fri, 3 Mar 2023 11:39:58 +0100
+Subject: [PATCH] Add some missing cstdint inclusions (#872)
+
+GCC 13 removed some indirect inclusions of cstdint which this relied on.
+Include it explicitly to fix build errors.
+---
+ include/mbgl/util/geometry.hpp | 2 ++
+ include/mbgl/util/string.hpp | 1 +
+ src/mbgl/gl/stencil_mode.hpp | 2 ++
+ 3 files changed, 5 insertions(+)
+
+diff --git a/include/mbgl/util/geometry.hpp b/include/mbgl/util/geometry.hpp
+index a28c59a47d..283ec7dbbe 100644
+--- a/src/3rdparty/mapbox-gl-native/include/mbgl/util/geometry.hpp
++++ b/src/3rdparty/mapbox-gl-native/include/mbgl/util/geometry.hpp
+@@ -1,5 +1,7 @@
+ #pragma once
+
++#include <cstdint>
++
+ #include <mapbox/geometry/geometry.hpp>
+ #include <mapbox/geometry/point_arithmetic.hpp>
+ #include <mapbox/geometry/for_each_point.hpp>
+diff --git a/include/mbgl/util/string.hpp b/include/mbgl/util/string.hpp
+index 13498ccb92..2f6acb6410 100644
+--- a/src/3rdparty/mapbox-gl-native/include/mbgl/util/string.hpp
++++ b/src/3rdparty/mapbox-gl-native/include/mbgl/util/string.hpp
+@@ -3,6 +3,7 @@
+ #include <sstream>
+ #include <string>
+ #include <cassert>
++#include <cstdint>
+ #include <cstdlib>
+ #include <exception>
+
+diff --git a/src/mbgl/gl/stencil_mode.hpp b/src/mbgl/gl/stencil_mode.hpp
+index bc959c9a73..fd00370f88 100644
+--- a/src/3rdparty/mapbox-gl-native/src/mbgl/gl/stencil_mode.hpp
++++ b/src/3rdparty/mapbox-gl-native/src/mbgl/gl/stencil_mode.hpp
+@@ -1,5 +1,7 @@
+ #pragma once
+
++#include <cstdint>
++
+ #include <mbgl/util/variant.hpp>
+
+ namespace mbgl {
+--
+GitLab
diff --git a/dev-qt/qtlocation/qtlocation-5.15.8.ebuild b/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
index 219efff528b3..a1ab77f7306e 100644
--- a/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
+++ b/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
@@ -39,6 +39,8 @@ QT5_TARGET_SUBDIRS=(
src/plugins/geoservices
)
+PATCHES=( "${FILESDIR}/${P}-mapboxgl-gcc13.patch" ) # bug 885431
+
src_configure() {
# src/plugins/geoservices requires files that are only generated when
# qmake is run in the root directory. Bug 633776.