summaryrefslogtreecommitdiff
path: root/dev-qt/qtpaths/qtpaths-5.15.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-qt/qtpaths/qtpaths-5.15.3.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-qt/qtpaths/qtpaths-5.15.3.ebuild')
-rw-r--r--dev-qt/qtpaths/qtpaths-5.15.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-qt/qtpaths/qtpaths-5.15.3.ebuild b/dev-qt/qtpaths/qtpaths-5.15.3.ebuild
new file mode 100644
index 000000000000..ac308c01b172
--- /dev/null
+++ b/dev-qt/qtpaths/qtpaths-5.15.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_KDEPATCHSET_REV=1
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Command line client to QStandardPaths"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/qtpaths
+)
+
+src_install() {
+ qt5-build_src_install
+ qt5_symlink_binary_to_path qtpaths 5
+}