summaryrefslogtreecommitdiff
path: root/dev-qt/qtremoteobjects
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-26 19:26:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-26 19:26:07 +0000
commitacfd7c956a7b45da7af1452ec12e0b2d5e6ac65b (patch)
tree13151a7440c2560b01e3cf5bd56ad280482b88bf /dev-qt/qtremoteobjects
parent67dbd3ba144944fbf4b466be1b5fa0569b774e6f (diff)
gentoo auto-resync : 26:02:2025 - 19:26:07
Diffstat (limited to 'dev-qt/qtremoteobjects')
-rw-r--r--dev-qt/qtremoteobjects/Manifest2
-rw-r--r--dev-qt/qtremoteobjects/qtremoteobjects-6.8.1.ebuild54
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-qt/qtremoteobjects/Manifest b/dev-qt/qtremoteobjects/Manifest
index 14cba6886310..05677da7d41f 100644
--- a/dev-qt/qtremoteobjects/Manifest
+++ b/dev-qt/qtremoteobjects/Manifest
@@ -1,6 +1,4 @@
-DIST qtremoteobjects-everywhere-src-6.8.1.tar.xz 537132 BLAKE2B b00cc0fd193c7b2638ed5ac2b91cdb6cc23cd8ff0b49ec55ef44cbd8633b0a62107e7ba69e6f2e5a0003d62138e8a88511483d2cfbd5616afc3fd8f5aff409b2 SHA512 30660149a59b8c7630fcafaf6d735b6ed0dc950c2658e7547c63c73f73468e5cbb4c3490a8849fabf9b021393b9c745ec339e7db909184711f05f3d30ab794cf
DIST qtremoteobjects-everywhere-src-6.8.2.tar.xz 537584 BLAKE2B fe60e78f1104b886f85e677901c38374646114d2479c79aa9f4b36db712a22f0150560949bca37fd7d980c366f2b878c6998dd1e9bda4418f649c0b76a9d17e8 SHA512 69668b986a1a4eefb0f2fac3bb53b6cd44b808def7307eb83c30af879d36156b06ced71ccf7746b56f503c927b7aac82ae6526ffe5f186ef1caa3dead39b388c
-EBUILD qtremoteobjects-6.8.1.ebuild 1147 BLAKE2B 699dc10da03632bca153daaf052bd35b5023a448ac392abf52679e06ec2f57b6774394f6a57e5cb1534217a3a97da41a75dd1b6546083104034eca0def205aaa SHA512 358606bcb566f49246fddd7392b3ac92558dacebd2bfef7b27bf1110dad105c0c3ce6510c3bbe91c6474cf64c72902d5cc12287ae5d2aa5f56e1e6dc607029a4
EBUILD qtremoteobjects-6.8.2.ebuild 1147 BLAKE2B 699dc10da03632bca153daaf052bd35b5023a448ac392abf52679e06ec2f57b6774394f6a57e5cb1534217a3a97da41a75dd1b6546083104034eca0def205aaa SHA512 358606bcb566f49246fddd7392b3ac92558dacebd2bfef7b27bf1110dad105c0c3ce6510c3bbe91c6474cf64c72902d5cc12287ae5d2aa5f56e1e6dc607029a4
EBUILD qtremoteobjects-6.8.9999.ebuild 1148 BLAKE2B cfad52a20a9f1441ee253cca50941c8c484c68c44b6a129b1d8453bb861f6f8a51d9f9964437eaf19f294d89884adf3ffe818c251b375a431be17c6feb77df9f SHA512 2f862440be1b98dd052c6055bd95a7998140180d6cf316200682e3b49a784a65415e937d9887a393cc2cf66a4576e07ac21b1b65e565369e4a4e3d9192b3179c
EBUILD qtremoteobjects-6.9.9999.ebuild 1148 BLAKE2B cfad52a20a9f1441ee253cca50941c8c484c68c44b6a129b1d8453bb861f6f8a51d9f9964437eaf19f294d89884adf3ffe818c251b375a431be17c6feb77df9f SHA512 2f862440be1b98dd052c6055bd95a7998140180d6cf316200682e3b49a784a65415e937d9887a393cc2cf66a4576e07ac21b1b65e565369e4a4e3d9192b3179c
diff --git a/dev-qt/qtremoteobjects/qtremoteobjects-6.8.1.ebuild b/dev-qt/qtremoteobjects/qtremoteobjects-6.8.1.ebuild
deleted file mode 100644
index d4438f8aaaaa..000000000000
--- a/dev-qt/qtremoteobjects/qtremoteobjects-6.8.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2024-2025 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Inter-Process Communication (IPC) library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 ~loong"
-fi
-
-IUSE="qml"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[network]
- qml? (
- ~dev-qt/qtbase-${PV}:6[gui]
- ~dev-qt/qtdeclarative-${PV}:6
- )
-"
-DEPEND="
- ${RDEPEND}
- test? ( ~dev-qt/qtbase-${PV}:6[gui] )
-"
-
-src_configure() {
- # same issue as bug #913692 when tests are enabled
- has_version "=dev-qt/qtdeclarative-$(ver_cut 1-3)*:6" &&
- local mycmakeargs=( $(cmake_use_find_package qml Qt6Qml) )
-
- qt6-build_src_configure
-}
-
-src_test() {
- local CMAKE_SKIP_TESTS=(
- # rarely fails randomly even with -j1, not looked further into
- tst_modelview
- )
-
- # tests re-use 127.0.0.1:65213 and randomly fail if ran at same time
- qt6-build_src_test -j1
-}
-
-src_install() {
- qt6-build_src_install
-
- if use test; then
- # installs 30+ test binaries like "qt6/bin/state" and, given
- # otherwise empty, "can" delete the directory rather than list
- rm -r -- "${D}${QT6_BINDIR}" || die
- fi
-}