summaryrefslogtreecommitdiff
path: root/dev-qt/qtscxml/qtscxml-6.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-05 16:23:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-05 16:23:54 +0100
commit44a22ab89258383202cae3037c3a5685aa903251 (patch)
tree76789a8fb67642ae7635df789a9bb83125ec127d /dev-qt/qtscxml/qtscxml-6.9999.ebuild
parent9aa62a2a35904a08cbf2e884d3abd89d893daf91 (diff)
gentoo auto-resync : 05:09:2023 - 16:23:54
Diffstat (limited to 'dev-qt/qtscxml/qtscxml-6.9999.ebuild')
-rw-r--r--dev-qt/qtscxml/qtscxml-6.9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/qtscxml-6.9999.ebuild b/dev-qt/qtscxml/qtscxml-6.9999.ebuild
new file mode 100644
index 000000000000..c3e29fd2e2f0
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui,network,opengl,widgets]
+ ~dev-qt/qtdeclarative-${PV}:6
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, consider flaky)
+ tst_qstatemachine
+)