summaryrefslogtreecommitdiff
path: root/dev-qt/qttools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-20 01:53:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-20 01:53:29 +0000
commit54d0ccbac3b6fbd01dcd252ea006d4e9e62f8e6e (patch)
treefc8f42b6568c9de11a72455118288dee202ce586 /dev-qt/qttools
parent3f0a9aff8dc766c410952343d02561aab3eda2b9 (diff)
gentoo auto-resync : 20:12:2023 - 01:53:29
Diffstat (limited to 'dev-qt/qttools')
-rw-r--r--dev-qt/qttools/Manifest2
-rw-r--r--dev-qt/qttools/qttools-6.5.3.ebuild143
2 files changed, 0 insertions, 145 deletions
diff --git a/dev-qt/qttools/Manifest b/dev-qt/qttools/Manifest
index 086605fcb6d4..0b2e10335f69 100644
--- a/dev-qt/qttools/Manifest
+++ b/dev-qt/qttools/Manifest
@@ -1,6 +1,4 @@
-DIST qttools-everywhere-src-6.5.3.tar.xz 8591996 BLAKE2B 072b0b49182fac824364e7ac71df5698009ce0e8f144422c752373e122c587f6bdb306c2bb605c39228d8d5a1c1e0a89c8d56daef5f3de1cbb66aeb53e036962 SHA512 7e383cdc575400d19051232dc563eaf330209605f28a93ac01f32921d0d966bc9a51bb5b56fb8f5c00ed4aab5fa2806b3bd0c8750aa2f49f5a04c85fa68fe30b
DIST qttools-everywhere-src-6.6.1.tar.xz 8583536 BLAKE2B c52fd1643f925909c2e5f677574ee202c0de5b810e9ca603f27511b123ce570c4bbf4aa3efd2c4347dace91d92546f5cb90e7ca783b7182369d13dcdbdac2db4 SHA512 7f7bfaf7f01a5374f711c20113e9461b83a6f908b48c7b3f662f8821a70ef0c792f040f2e8e62a570fec06df2329fe5eb953c680424262b3678ab283045e6909
-EBUILD qttools-6.5.3.ebuild 4333 BLAKE2B 43559dce18d9652d84b6c9a759ea998cfbfa37b98227b943121c2113a9b470f9a40fc12e4a23adb110bad04ba9c07d489a854f21b6ac9cec9c680cb7da6b07e9 SHA512 c5268a14aee074dca0a667ecd933ac8380a1585522c16a2cb0e087b243e111036da1503164050c8739af7b7da90423514ce2a20f1544db24a8df49757e488567
EBUILD qttools-6.6.1.ebuild 4499 BLAKE2B f3765a82003b42f1b097b25233d63ed6d861943e55071bca07f5bac1e85cb2734e215b0c712677efcb82e0382c49cc2a399ad611796551101f757f94364603dd SHA512 fe9b7fcbe1c03f1c5f1336fe892123f02efde25227d4c300e41167675670a9edbe98b81c69547b6c64e86584d5a1bbd20a8482194b50520e73348f3d6c697074
EBUILD qttools-6.6.9999.ebuild 4474 BLAKE2B 71bcaf3beee737d882111ff5195c48a633c4ded4437c6748e75309be428c38af0eea47d4bda0e387c9ecaf8a2e3bb8361c5cb91f4575744be5dda3df78ae9c3f SHA512 ac94405b3ba36afc4ea01bd83cfaec0bab216c51191a12a5d45a6dc287ad7d81411457164c9a7f55dc07def763fd66c74a8748f752c625e03bbdbfbdbd06632b
EBUILD qttools-6.7.9999.ebuild 4626 BLAKE2B 52bae536d87d31c5ff476ac06fd9eb238c29fa3479c8324a49953b358ea42876ce790373f136d4afdbd96d8b1d4417c6549b9e01a369f1225eb09c9d5b4ce31f SHA512 1fbb84ab8e514c77b762d0e44134338cfd8eecc80e4dbc13add66b8fbd9970b341922c408a800264e3d0b353304fda7bcacdc607af005a6f3349217a23e67a9e
diff --git a/dev-qt/qttools/qttools-6.5.3.ebuild b/dev-qt/qttools/qttools-6.5.3.ebuild
deleted file mode 100644
index 679892cbe83a..000000000000
--- a/dev-qt/qttools/qttools-6.5.3.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit desktop llvm optfeature qt6-build
-
-DESCRIPTION="Qt Tools Collection"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 ~arm ~arm64 ~hppa ~loong ~x86"
-fi
-
-IUSE="
- +assistant clang designer distancefieldgenerator gles2-only
- +linguist opengl pixeltool qdbus qdoc qml qtattributionsscanner
- qtdiag qtplugininfo vulkan +widgets
-"
-# note that some tools do not *require* widgets but will skip a sub-tool
-# if not enabled (e.g. linguist gives lrelease but not the GUI linguist6)
-REQUIRED_USE="
- assistant? ( widgets )
- designer? ( qml widgets )
- distancefieldgenerator? ( qml widgets )
- pixeltool? ( widgets )
- qdoc? ( clang )
-"
-
-# behaves very badly when qttools is not already installed, also
-# other more minor issues (clang tests flaky depending on version,
-# and 3rdparty/ tries to FetchContent gtest)
-RESTRICT="test"
-
-LLVM_MAX_SLOT=17
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[network,widgets?]
- assistant? ( ~dev-qt/qtbase-${PV}:6[sql,sqlite] )
- clang? ( <sys-devel/clang-$((LLVM_MAX_SLOT+1)):= )
- designer? ( ~dev-qt/qtbase-${PV}:6[xml] )
- qdbus? ( ~dev-qt/qtbase-${PV}:6[dbus,xml] )
- qml? ( ~dev-qt/qtdeclarative-${PV}:6[widgets?] )
- qtdiag? ( ~dev-qt/qtbase-${PV}:6[gles2-only=,vulkan=] )
- widgets? ( ~dev-qt/qtbase-${PV}:6[opengl=] )
-"
-DEPEND="
- ${RDEPEND}
- qtdiag? (
- vulkan? ( dev-util/vulkan-headers )
- )
-"
-
-llvm_check_deps() {
- has_version -d "sys-devel/clang:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- use clang && llvm_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package qml Qt6Qml)
- $(cmake_use_find_package widgets Qt6Widgets)
- $(qt_feature assistant)
- $(qt_feature clang clangcpp)
- $(qt_feature designer)
- $(qt_feature distancefieldgenerator)
- $(qt_feature linguist)
- $(qt_feature pixeltool)
- $(qt_feature qdbus)
- $(qt_feature qdoc clang)
- $(qt_feature qtattributionsscanner)
- $(qt_feature qtdiag)
- $(qt_feature qtplugininfo)
-
- # TODO?: package litehtml, but support for latest releases seem
- # to lag behind and bundled may work out better for now
- # https://github.com/litehtml/litehtml/issues/266
- $(usev assistant -DCMAKE_DISABLE_FIND_PACKAGE_litehtml=ON)
- )
-
- qt6-build_src_configure
-}
-
-src_install() {
- qt6-build_src_install
-
- if use widgets; then #914766
- use designer || use distancefieldgenerator || use pixeltool &&
- newicon src/designer/src/designer/images/designer.png designer6.png
-
- if use assistant; then
- make_desktop_entry assistant6 'Qt 6 Assistant' assistant6 \
- 'Qt;Development;Documentation' \
- 'Comment=Tool for viewing online documentation in Qt help file format'
- newicon src/assistant/assistant/images/assistant-128.png assistant6.png
- fi
-
- if use designer; then
- make_desktop_entry designer6 'Qt 6 Designer' designer6 \
- 'Qt;Development;GUIDesigner' \
- 'Comment=WYSIWYG tool for designing and building graphical user interfaces with QtWidgets'
- fi
-
- if use distancefieldgenerator; then
- # no icon, sharing with designer which fits letter-wise
- make_desktop_entry qdistancefieldgenerator6 'Qt 6 Distance Field Generator' designer6 \
- 'Qt;Development' \
- 'Comment=Tool for pregenerating the font cache of Qt applications'
- fi
-
- if use linguist; then
- make_desktop_entry linguist6 'Qt 6 Linguist' linguist6 \
- 'Qt;Development;Translation' \
- 'Comment=Tool for translating Qt applications'
- newicon src/linguist/linguist/images/icons/linguist-128-32.png linguist6.png
- fi
-
- if use pixeltool; then
- # no icon, not fitting but share with designer for now
- make_desktop_entry pixeltool6 'Qt 6 Pixel Tool' designer6 \
- 'Qt;Development' \
- 'Comment=Tool for zooming in the desktop area pointed by the cursor'
- fi
-
- if use qdbus; then
- make_desktop_entry qdbusviewer6 'Qt 6 QDBusViewer' qdbusviewer6 \
- 'Qt;Development' \
- 'Comment=Tool that lets introspect D-Bus objects and messages'
- newicon src/qdbus/qdbusviewer/images/qdbusviewer-128.png qdbusviewer6.png
- fi
-
- # hack: make_destop_entry does not support overriding DESCRIPTION
- find "${ED}" -type f -name "*.desktop" \
- -exec sed -i "/^Comment=${DESCRIPTION}/d" -- {} + || die
- fi
-}
-
-pkg_postinst() {
- use assistant &&
- optfeature "Qt documentation viewable in assistant" \
- 'dev-qt/qt-docs:6[qch]' #602296
-}