summaryrefslogtreecommitdiff
path: root/dev-qt/qtxml/qtxml-5.15.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-23 19:01:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-23 19:01:15 +0000
commit36fc50e36ed1a4686bb7202aeaff3170b2206124 (patch)
tree7b5feb28a3ad8ba78d57f64c93cc796cff95cd53 /dev-qt/qtxml/qtxml-5.15.13.ebuild
parentacc2dacf2ee9a5b03df96da670153f2e3a24d80c (diff)
gentoo auto-resync : 23:03:2024 - 19:01:14
Diffstat (limited to 'dev-qt/qtxml/qtxml-5.15.13.ebuild')
-rw-r--r--dev-qt/qtxml/qtxml-5.15.13.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-qt/qtxml/qtxml-5.15.13.ebuild b/dev-qt/qtxml/qtxml-5.15.13.ebuild
new file mode 100644
index 000000000000..a3f3a0d21977
--- /dev/null
+++ b/dev-qt/qtxml/qtxml-5.15.13.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Implementation of SAX and DOM for the Qt5 framework"
+
+IUSE=""
+
+RDEPEND="=dev-qt/qtcore-${QT5_PV}*:5="
+DEPEND="${RDEPEND}
+ test? ( =dev-qt/qtnetwork-${QT5_PV}* )
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/xml
+)
+
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :xml
+)