summaryrefslogtreecommitdiff
path: root/dev-qt/qtxmlpatterns/qtxmlpatterns-5.15.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-qt/qtxmlpatterns/qtxmlpatterns-5.15.2-r1.ebuild
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-qt/qtxmlpatterns/qtxmlpatterns-5.15.2-r1.ebuild')
-rw-r--r--dev-qt/qtxmlpatterns/qtxmlpatterns-5.15.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-qt/qtxmlpatterns/qtxmlpatterns-5.15.2-r1.ebuild b/dev-qt/qtxmlpatterns/qtxmlpatterns-5.15.2-r1.ebuild
new file mode 100644
index 000000000000..20f6cb72b150
--- /dev/null
+++ b/dev-qt/qtxmlpatterns/qtxmlpatterns-5.15.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt5-build
+
+DESCRIPTION="XPath, XQuery, XSLT, and XML Schema validation library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
+fi
+
+IUSE="qml"
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_mod qml qml \
+ src/src.pro \
+ src/imports/imports.pro
+
+ qt_use_disable_mod qml quick tests/auto/auto.pro
+
+ qt5-build_src_prepare
+}