summaryrefslogtreecommitdiff
path: root/dev-ros/actionlib/actionlib-1.11.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /dev-ros/actionlib/actionlib-1.11.13.ebuild
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'dev-ros/actionlib/actionlib-1.11.13.ebuild')
-rw-r--r--dev-ros/actionlib/actionlib-1.11.13.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/actionlib/actionlib-1.11.13.ebuild b/dev-ros/actionlib/actionlib-1.11.13.ebuild
new file mode 100644
index 000000000000..72617b6f8b23
--- /dev/null
+++ b/dev-ros/actionlib/actionlib-1.11.13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/actionlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a standardized interface for interfacing with preemptable tasks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
+RDEPEND="${RDEPEND}
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+"