summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cmake_ros
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/ament_cmake_ros
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/ament_cmake_ros')
-rw-r--r--dev-ros/ament_cmake_ros/Manifest4
-rw-r--r--dev-ros/ament_cmake_ros/ament_cmake_ros-0.9.0.ebuild54
-rw-r--r--dev-ros/ament_cmake_ros/ament_cmake_ros-9999.ebuild54
-rw-r--r--dev-ros/ament_cmake_ros/metadata.xml11
4 files changed, 123 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_ros/Manifest b/dev-ros/ament_cmake_ros/Manifest
new file mode 100644
index 000000000000..08cf4e40249b
--- /dev/null
+++ b/dev-ros/ament_cmake_ros/Manifest
@@ -0,0 +1,4 @@
+DIST ament_cmake_ros-0.9.0.tar.gz 10247 BLAKE2B 7492dae5b9925c2de5c6d775bec40a00c82eddd4f62ce9bfe51d745eebcc453646088b448b2e26a6d92a38ccc343e36c0ab9bcb7ec307265c1467c9129cd9aad SHA512 3c18cb88b943f06edcf3b83ba18b958997583ee733545faf8e8a9f2008a7d5da47f0479ddce6f32afefcc1a316304e78b1d36566ea6de77a89b3c64871bea766
+EBUILD ament_cmake_ros-0.9.0.ebuild 1107 BLAKE2B fe46df60d93e9f7bdb7435b031d6f637df4268d313d02f1df0fec93f03fa90a0aed51fa81d91a995507becbfa54f281ee1540850a94567eb9df69742ae5494c1 SHA512 48175c16d15da9e7ff292d573ffc65837e87cb6d7496958141785541064a7f6e6ef90f70eac6c64d87447dfcfdc4833229e0ab4ce35410a98e2db35dda554167
+EBUILD ament_cmake_ros-9999.ebuild 1107 BLAKE2B fe46df60d93e9f7bdb7435b031d6f637df4268d313d02f1df0fec93f03fa90a0aed51fa81d91a995507becbfa54f281ee1540850a94567eb9df69742ae5494c1 SHA512 48175c16d15da9e7ff292d573ffc65837e87cb6d7496958141785541064a7f6e6ef90f70eac6c64d87447dfcfdc4833229e0ab4ce35410a98e2db35dda554167
+MISC metadata.xml 334 BLAKE2B 31ad71fc081aaff06e8df868becdce6a5534f0c87ade8bc8525b1b2f9c9ba2fd750707cfbc2bc49fad70f5c353c25b07c81ac15fbf75bcdc33f307790f524a06 SHA512 e9725870b6ea4b7da5fd243399548a74dcff4c0cd6acb0b1ff3d72f35710cb1d70ec7bc0d6082e468599294f44308476ed9e2194785712b40bbb9a4d9a3a15a6
diff --git a/dev-ros/ament_cmake_ros/ament_cmake_ros-0.9.0.ebuild b/dev-ros/ament_cmake_ros/ament_cmake_ros-0.9.0.ebuild
new file mode 100644
index 000000000000..d0cf50beea1c
--- /dev/null
+++ b/dev-ros/ament_cmake_ros/ament_cmake_ros-0.9.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_cmake_ros"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ros2/ament_cmake_ros"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ros2/ament_cmake_ros/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="ROS specific CMake bits in the ament buildsystem"
+HOMEPAGE="https://github.com/ros2/ament_cmake_ros"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ test? (
+ dev-ros/ament_lint_auto
+ )
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}
diff --git a/dev-ros/ament_cmake_ros/ament_cmake_ros-9999.ebuild b/dev-ros/ament_cmake_ros/ament_cmake_ros-9999.ebuild
new file mode 100644
index 000000000000..d0cf50beea1c
--- /dev/null
+++ b/dev-ros/ament_cmake_ros/ament_cmake_ros-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_cmake_ros"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ros2/ament_cmake_ros"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ros2/ament_cmake_ros/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="ROS specific CMake bits in the ament buildsystem"
+HOMEPAGE="https://github.com/ros2/ament_cmake_ros"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ test? (
+ dev-ros/ament_lint_auto
+ )
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}
diff --git a/dev-ros/ament_cmake_ros/metadata.xml b/dev-ros/ament_cmake_ros/metadata.xml
new file mode 100644
index 000000000000..c4507367383c
--- /dev/null
+++ b/dev-ros/ament_cmake_ros/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros2/ament_cmake_ros</remote-id>
+ </upstream>
+</pkgmetadata>