summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild')
-rw-r--r--dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild b/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild
index 938e0193c306..00d8aa0613ba 100644
--- a/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild
+++ b/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit cmake-utils python-r1
+inherit cmake python-r1
ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -42,18 +42,18 @@ BDEPEND="${DEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
src_configure() {
- python_foreach_impl cmake-utils_src_configure
+ python_foreach_impl cmake_src_configure
}
src_compile() {
- python_foreach_impl cmake-utils_src_compile
+ python_foreach_impl cmake_src_compile
}
src_test() {
- python_foreach_impl cmake-utils_src_test
+ python_foreach_impl cmake_src_test
}
src_install() {
- python_foreach_impl cmake-utils_src_install
+ python_foreach_impl cmake_src_install
python_foreach_impl python_optimize
}