summaryrefslogtreecommitdiff
path: root/dev-ros/calibration_estimation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/calibration_estimation
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/calibration_estimation')
-rw-r--r--dev-ros/calibration_estimation/Manifest6
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-0.10.13.ebuild30
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild30
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-9999.ebuild30
-rw-r--r--dev-ros/calibration_estimation/metadata.xml11
5 files changed, 107 insertions, 0 deletions
diff --git a/dev-ros/calibration_estimation/Manifest b/dev-ros/calibration_estimation/Manifest
new file mode 100644
index 000000000000..d37ab1fc427e
--- /dev/null
+++ b/dev-ros/calibration_estimation/Manifest
@@ -0,0 +1,6 @@
+DIST calibration-0.10.13.tar.gz 112305 BLAKE2B 1b2c2ffa0c07b907c7a4dc28b87ff112a497275039be98bcc15ad396ccf525ba4fb717b398551f04dab7131a8085e1b1ec64eb24408c12fec09e9c42b5c40a75 SHA512 95b5ea28428ea9726b6b1a8f24cd4c7cb84992e680761357c1a13dd92c362149a0a6104f6a44dbefad503db1a9c7a53135d9756b1ceea3a739b1baa14f9474eb
+DIST calibration-0.10.14.tar.gz 112475 BLAKE2B a43bf316b3eea30f5f3e273e0dd2754fe819a1aa246237cb1ecc4bc49463abbd3eb71f77579fc0655c483ad9ac259bb027ac014fc5ec368a73bada61dedf6712 SHA512 5ef17cd21e04c134717859ecb12c4e7fc0086b044cf7d35d40bd43439a0f24e8ad41fe7b5fa37dcc8ec5e4abb2be8f64d86510706a3d97510cf1b92c2196ad40
+EBUILD calibration_estimation-0.10.13.ebuild 894 BLAKE2B 5ce9e71bfe04e4ddf1543698bb03f2e3a172e7d8cfd27a2ad71c77f31b233f1e6e94ae5823ec0f230a80c2fe37488fdd1ace2d7ca4bd8504267a8802a646219b SHA512 44640c1e0eef9d9b90e601e343dd84cc82af314cfc5399173b35f4abd66d889cafa7a09ce16a59c9e8d34a323e00205b587e621fcac3ce51dde55fe054acf491
+EBUILD calibration_estimation-0.10.14.ebuild 894 BLAKE2B 5ce9e71bfe04e4ddf1543698bb03f2e3a172e7d8cfd27a2ad71c77f31b233f1e6e94ae5823ec0f230a80c2fe37488fdd1ace2d7ca4bd8504267a8802a646219b SHA512 44640c1e0eef9d9b90e601e343dd84cc82af314cfc5399173b35f4abd66d889cafa7a09ce16a59c9e8d34a323e00205b587e621fcac3ce51dde55fe054acf491
+EBUILD calibration_estimation-9999.ebuild 894 BLAKE2B 5ce9e71bfe04e4ddf1543698bb03f2e3a172e7d8cfd27a2ad71c77f31b233f1e6e94ae5823ec0f230a80c2fe37488fdd1ace2d7ca4bd8504267a8802a646219b SHA512 44640c1e0eef9d9b90e601e343dd84cc82af314cfc5399173b35f4abd66d889cafa7a09ce16a59c9e8d34a323e00205b587e621fcac3ce51dde55fe054acf491
+MISC metadata.xml 340 BLAKE2B 52b47839e0051b2f1813313ae3989819be9668c093763a9c9518302d5b5832142fd02e6c7427493411d2b3ad3143d41180aa1c0f890362b43258109fc5b858b3 SHA512 de7b08cf3292d6c46f7a6e954ece0a32c8e2f4d67bc5212ce755662b8abf50425d54c00e0601ba943a4a9835f32c3df63ef87d5655788510ed86f05dd485a963
diff --git a/dev-ros/calibration_estimation/calibration_estimation-0.10.13.ebuild b/dev-ros/calibration_estimation/calibration_estimation-0.10.13.ebuild
new file mode 100644
index 000000000000..bbce471d0c6c
--- /dev/null
+++ b/dev-ros/calibration_estimation/calibration_estimation-0.10.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Runs an optimization to estimate the a robot's kinematic parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/urdf_parser_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild b/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
new file mode 100644
index 000000000000..bbce471d0c6c
--- /dev/null
+++ b/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Runs an optimization to estimate the a robot's kinematic parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/urdf_parser_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild b/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild
new file mode 100644
index 000000000000..bbce471d0c6c
--- /dev/null
+++ b/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Runs an optimization to estimate the a robot's kinematic parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/urdf_parser_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/calibration_estimation/metadata.xml b/dev-ros/calibration_estimation/metadata.xml
new file mode 100644
index 000000000000..660014a7883d
--- /dev/null
+++ b/dev-ros/calibration_estimation/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/calibration</remote-id>
+ </upstream>
+</pkgmetadata>