summaryrefslogtreecommitdiff
path: root/dev-ros/compressed_image_transport/compressed_image_transport-1.9.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /dev-ros/compressed_image_transport/compressed_image_transport-1.9.5-r1.ebuild
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'dev-ros/compressed_image_transport/compressed_image_transport-1.9.5-r1.ebuild')
-rw-r--r--dev-ros/compressed_image_transport/compressed_image_transport-1.9.5-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/compressed_image_transport/compressed_image_transport-1.9.5-r1.ebuild b/dev-ros/compressed_image_transport/compressed_image_transport-1.9.5-r1.ebuild
new file mode 100644
index 000000000000..46fc32014194
--- /dev/null
+++ b/dev-ros/compressed_image_transport/compressed_image_transport-1.9.5-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending images encoded as JPEG or PNG"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_transport
+ media-libs/opencv:=
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"