summaryrefslogtreecommitdiff
path: root/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild')
-rw-r--r--dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild b/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
new file mode 100644
index 000000000000..9d08355634bd
--- /dev/null
+++ b/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-any-r1
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ros2/console_bridge_vendor"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/ros2/console_bridge_vendor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Wrapper around console_bridge"
+HOMEPAGE="https://github.com/ros2/console_bridge_vendor"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ >=dev-libs/console_bridge-0.4.1
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"