summaryrefslogtreecommitdiff
path: root/dev-ros/controller_manager/controller_manager-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/controller_manager/controller_manager-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/controller_manager/controller_manager-9999.ebuild')
-rw-r--r--dev-ros/controller_manager/controller_manager-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/controller_manager/controller_manager-9999.ebuild b/dev-ros/controller_manager/controller_manager-9999.ebuild
new file mode 100644
index 000000000000..f250c32a65e7
--- /dev/null
+++ b/dev-ros/controller_manager/controller_manager-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/ros_control"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="The controller manager"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/controller_interface
+ >=dev-ros/controller_manager_msgs-0.10.0[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/hardware_interface-0.10.0
+ dev-ros/realtime_tools
+ dev-ros/pluginlib
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosparam[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"