summaryrefslogtreecommitdiff
path: root/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.2-r1.ebuild
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.2-r1.ebuild')
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.2-r1.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.2-r1.ebuild
new file mode 100644
index 000000000000..7a610fadd9fb
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates ROS diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+ dev-ros/xmlrpcpp
+ dev-ros/bondcpp
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )"