summaryrefslogtreecommitdiff
path: root/dev-ros/diagnostic_aggregator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/diagnostic_aggregator
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/diagnostic_aggregator')
-rw-r--r--dev-ros/diagnostic_aggregator/Manifest6
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.2-r1.ebuild29
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.3.ebuild29
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild29
-rw-r--r--dev-ros/diagnostic_aggregator/metadata.xml11
5 files changed, 104 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_aggregator/Manifest b/dev-ros/diagnostic_aggregator/Manifest
new file mode 100644
index 000000000000..95dcbd7e82a4
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/Manifest
@@ -0,0 +1,6 @@
+DIST diagnostics-1.9.2.tar.gz 530844 BLAKE2B 9b67f24df11ec5a716bd80ae7eb0f80f777c3014c4c0ed115e15f67649245bb685c13502a8e7889fe02bdcce43d465c11c0b2d448b698716aebed25c23512883 SHA512 6074b7fb6366bc40252af6317b27f509ee969f30c532fae47bba506f4851656d8bef041bea6256046325316807ba4d9e570f695d517b562970ecaf72d2def759
+DIST diagnostics-1.9.3.tar.gz 531618 BLAKE2B 10bbf697477d58cfe405e6634259af4125792be873bc38aa899d09089c4162a2107d5910bcba670edb5df77d5692b9c57070a4eca911c648c7a4a25d2ffa9f07 SHA512 56e97ea5751c82acc18e7098d0449c7be271c91a191d363671ff118bedb9797d0b5568394c929d534d73560ff9048915d0693aa0b66942761fb12ed255f6f1b7
+EBUILD diagnostic_aggregator-1.9.2-r1.ebuild 583 BLAKE2B bd9ec81e5f2d2fe41ee77bab6072bd87e7e4fd749471ac5d9672fd866df215fda5eaf6fe8f775717dc94144eccfd4e4b74a2aecd0edca252d385d45c64467c7d SHA512 77b3f633a06959a282f69aa0d73951fc5b83ceb85f2bfcce8b9f0a31f8130b7fa2e8fc4d4a546c1b009be21d3e39d165dafc537f386a25afb4e8a6b8df525845
+EBUILD diagnostic_aggregator-1.9.3.ebuild 583 BLAKE2B ab074a4b081d313ebdfd1744d030050e90c16aab4c9b37ed3efc9b6d9ad46eed3f5a4a5ca2b9fc244e5d86ee0ff6ae2f0fa7610b661855bc019d4a474adea7fb SHA512 e5953c56c3c8d1d786c5adcd07c19646ac21f66250196cf35cc76b38a8d15b417c1e374d0a8e65ad371e74c9946a9463d519f94f7b909e0be3260a1765a97c77
+EBUILD diagnostic_aggregator-9999.ebuild 583 BLAKE2B bd9ec81e5f2d2fe41ee77bab6072bd87e7e4fd749471ac5d9672fd866df215fda5eaf6fe8f775717dc94144eccfd4e4b74a2aecd0edca252d385d45c64467c7d SHA512 77b3f633a06959a282f69aa0d73951fc5b83ceb85f2bfcce8b9f0a31f8130b7fa2e8fc4d4a546c1b009be21d3e39d165dafc537f386a25afb4e8a6b8df525845
+MISC metadata.xml 329 BLAKE2B 5e824b17ef204172c52c3091d08267568c131a28f752a12867316400e12ff989c417f921329fd48f759d2d14325fe1ff48eb0bce36ba693b3dcf8a2f897c7aa9 SHA512 38a2d063b6ed23109d1c79cff72f2bddea0a0f3cdc54a7f8e73c6c824b6855c120bbfe373fcd33473c25f6067ece4cd169a68c83c04163cd631a5e1253004e44
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.2-r1.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.2-r1.ebuild
new file mode 100644
index 000000000000..7a610fadd9fb
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates ROS diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+ dev-ros/xmlrpcpp
+ dev-ros/bondcpp
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )"
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.3.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.3.ebuild
new file mode 100644
index 000000000000..650ad537d33a
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates ROS diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+ dev-ros/xmlrpcpp
+ dev-ros/bondcpp
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )"
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
new file mode 100644
index 000000000000..7a610fadd9fb
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates ROS diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+ dev-ros/xmlrpcpp
+ dev-ros/bondcpp
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )"
diff --git a/dev-ros/diagnostic_aggregator/metadata.xml b/dev-ros/diagnostic_aggregator/metadata.xml
new file mode 100644
index 000000000000..6cc2de656785
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/diagnostics</remote-id>
+ </upstream>
+</pkgmetadata>