summaryrefslogtreecommitdiff
path: root/dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild')
-rw-r--r--dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild
index 45442499ccd4..150b8c47d782 100644
--- a/dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild
+++ b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild
@@ -1,23 +1,33 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
CATKIN_HAS_MESSAGES=yes
ROS_REPO_URI="https://github.com/ros/dynamic_reconfigure"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
inherit ros-catkin
-DESCRIPTION="Provides a means to change node parameters at any time without having to restart the node"
+DESCRIPTION="Provides a means to change node parameters at runtime"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
dev-libs/boost:=[threads]
- dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
dev-ros/roscpp
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ dev-ros/roslaunch
+ )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}