summaryrefslogtreecommitdiff
path: root/dev-ros/gmapping
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/gmapping
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/gmapping')
-rw-r--r--dev-ros/gmapping/Manifest4
-rw-r--r--dev-ros/gmapping/gmapping-1.3.10.ebuild26
-rw-r--r--dev-ros/gmapping/gmapping-9999.ebuild26
-rw-r--r--dev-ros/gmapping/metadata.xml11
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-ros/gmapping/Manifest b/dev-ros/gmapping/Manifest
new file mode 100644
index 000000000000..8f539baa8058
--- /dev/null
+++ b/dev-ros/gmapping/Manifest
@@ -0,0 +1,4 @@
+DIST slam_gmapping-1.3.10.tar.gz 21032 BLAKE2B cca0779e64d45622dad4ec29cb3c1d0162176038288c0aa7b117f1a76a7655f3af3024dba7ff1025948e400e0176794a553e357a235187d9196161a635ab6d01 SHA512 fa4485ddc9fcfaac63a63d209a5a994e33e78546a39edcf47eb3c3f1775f0d87a1f562319058868838990bbf85a9515ff0228779dce7531148f208b3522e7e7a
+EBUILD gmapping-1.3.10.ebuild 546 BLAKE2B 9a6c5e78a43ba77c86dd2a1640ef56bcd2f481a830c3333ab4b87f84f4c761c8728e811e5e314b5eed9809e987fd2b8a0a72aaf58b62f6c4dea561d2101682ad SHA512 41823e5fad9201ca764d2a22af8de2c88b19e449f8d2fec8682a5d21381e35f29a17b729d3b5cc5faacd50057fe5e69b110f7756b414b859528656bea3a963b8
+EBUILD gmapping-9999.ebuild 546 BLAKE2B 9a6c5e78a43ba77c86dd2a1640ef56bcd2f481a830c3333ab4b87f84f4c761c8728e811e5e314b5eed9809e987fd2b8a0a72aaf58b62f6c4dea561d2101682ad SHA512 41823e5fad9201ca764d2a22af8de2c88b19e449f8d2fec8682a5d21381e35f29a17b729d3b5cc5faacd50057fe5e69b110f7756b414b859528656bea3a963b8
+MISC metadata.xml 342 BLAKE2B 72a1fe4f1e7971418dbb3f5b1e78de71a77819b9fa7200feb2ce0abec5b50a5435c5e5541d290bfd23c7acee5a6920280934067c84e4716bd9f6bb0cc634544d SHA512 2a5beef664e8c79b9e4d858d0dc093068c6e462456ae6066ea637f4b725e5c7184dd65769906c34e55eb6b03949e957edba34b84a587e1daec784e1f74ea287c
diff --git a/dev-ros/gmapping/gmapping-1.3.10.ebuild b/dev-ros/gmapping/gmapping-1.3.10.ebuild
new file mode 100644
index 000000000000..ca6f43afe50c
--- /dev/null
+++ b/dev-ros/gmapping/gmapping-1.3.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/slam_gmapping"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for OpenSlam's Gmapping"
+LICENSE="CC-BY-NC-SA-2.5"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/openslam_gmapping
+ dev-ros/rosbag_storage
+ dev-ros/gmapping
+"
+DEPEND="${RDEPEND}
+ dev-ros/rostest"
diff --git a/dev-ros/gmapping/gmapping-9999.ebuild b/dev-ros/gmapping/gmapping-9999.ebuild
new file mode 100644
index 000000000000..ca6f43afe50c
--- /dev/null
+++ b/dev-ros/gmapping/gmapping-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/slam_gmapping"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for OpenSlam's Gmapping"
+LICENSE="CC-BY-NC-SA-2.5"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/openslam_gmapping
+ dev-ros/rosbag_storage
+ dev-ros/gmapping
+"
+DEPEND="${RDEPEND}
+ dev-ros/rostest"
diff --git a/dev-ros/gmapping/metadata.xml b/dev-ros/gmapping/metadata.xml
new file mode 100644
index 000000000000..a45ed347785d
--- /dev/null
+++ b/dev-ros/gmapping/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/slam_gmapping</remote-id>
+ </upstream>
+</pkgmetadata>