summaryrefslogtreecommitdiff
path: root/dev-ros/hector_pose_estimation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-ros/hector_pose_estimation
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-ros/hector_pose_estimation')
-rw-r--r--dev-ros/hector_pose_estimation/Manifest3
-rw-r--r--dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch19
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild4
3 files changed, 24 insertions, 2 deletions
diff --git a/dev-ros/hector_pose_estimation/Manifest b/dev-ros/hector_pose_estimation/Manifest
index 8471aba76525..2e61a693f644 100644
--- a/dev-ros/hector_pose_estimation/Manifest
+++ b/dev-ros/hector_pose_estimation/Manifest
@@ -1,4 +1,5 @@
+AUX hector_pose_estimation-0.3.0-pluginlib.patch 1014 BLAKE2B b98d2357c13d61919f32d45f19d267832d855a9a8490519c838540b2b7217227e854b53cced737dda7551bc61c99eff78fa61f6b7a3557271bd81e4cb6e9bb03 SHA512 a3e4f2e63aa1d639f8acb178032bb6e9d95640d478cf75715ceb0136bd150d704ada3ceac279932083126c79201bd1b530937f1d7182188bde9710c30f8fc6f7
DIST hector_localization-0.3.0.tar.gz 73656 BLAKE2B 8e895c760974f8707eb174b3b385f03f07f93f89b470d88140f1134a3cb9fb8e67e65a86484b702dbaed09e4d614f4c6759f1e08b536385f86ec15dc3db6a644 SHA512 5763a98247754b021631c894d44172d7c215d81f556760578f585febf2248da8dfcf10c6f1430cff47800778d39a79ab31a59916ad13c6d5ecf8a17eeac4e8df
-EBUILD hector_pose_estimation-0.3.0-r1.ebuild 711 BLAKE2B 67d3ab3da4f47e0b7784bc578f31983b5dca9c09b344d88c0c1f42355de74a126a5339b6179b8e43dc73693c8fe89e5384df3080bc742a05090f5ab250511834 SHA512 abeb93640c11c0d1359ce0e84adc9ce43b42461b259225f39c2189688a164ebc7d4f76195ca89c9e77a545f21b4dfd1e83ac13b07c657c063f86f95ca0a4da9b
+EBUILD hector_pose_estimation-0.3.0-r1.ebuild 763 BLAKE2B e0725468681b66e5717d69e3dc3f987b5e7b837f3a07d3da2738dce90392dea03f1656f4096dac90094e076f47e86522122c9767f31541d29cfd93d35f02ea9f SHA512 dc3cb0874189d1f82628c7393bf229ee1556895cefb6cc7e1f7579438c7b594f5232bfcd54ef6f3819bedab5219721f53fdee2ab5288f5d368b2965f8069428b
EBUILD hector_pose_estimation-9999.ebuild 711 BLAKE2B 67d3ab3da4f47e0b7784bc578f31983b5dca9c09b344d88c0c1f42355de74a126a5339b6179b8e43dc73693c8fe89e5384df3080bc742a05090f5ab250511834 SHA512 abeb93640c11c0d1359ce0e84adc9ce43b42461b259225f39c2189688a164ebc7d4f76195ca89c9e77a545f21b4dfd1e83ac13b07c657c063f86f95ca0a4da9b
MISC metadata.xml 354 BLAKE2B 8fa87680be83a7fc421afc00fa7e203bd512c42324cee5ce59f08a6acdfacdd09a8427e547982ccff17253589708a0556e51420188c3639ab638df4994e4edb7 SHA512 5efea6ff063bdb92ca5c0c45cbc4c9cc110d4ed800b8631259abdffb771abb183594d9e72920e0daf9948c909a69ab564b70fed83bb2a0a879d5712f3c608420
diff --git a/dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch b/dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch
new file mode 100644
index 000000000000..a226c40e9fce
--- /dev/null
+++ b/dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch
@@ -0,0 +1,19 @@
+From 6743fbe859981c2b52a2ab413175d7d2eaf33b47 Mon Sep 17 00:00:00 2001
+From: Mikael Arguedas <mikael@osrfoundation.org>
+Date: Fri, 27 Oct 2017 15:08:45 -0700
+Subject: [PATCH] update to use non deprecated pluginlib macro
+
+---
+ hector_pose_estimation/src/pose_estimation_nodelet.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/hector_pose_estimation/src/pose_estimation_nodelet.cpp b/hector_pose_estimation/src/pose_estimation_nodelet.cpp
+index 7da3ca6..97ba5b0 100644
+--- a/hector_pose_estimation/src/pose_estimation_nodelet.cpp
++++ b/hector_pose_estimation/src/pose_estimation_nodelet.cpp
+@@ -55,4 +55,4 @@ class PoseEstimationNodelet : public PoseEstimationNode, public nodelet::Nodelet
+ } // namespace hector_pose_estimation
+
+ #include <pluginlib/class_list_macros.h>
+-PLUGINLIB_DECLARE_CLASS(hector_pose_estimation, PoseEstimation, hector_pose_estimation::PoseEstimationNodelet, nodelet::Nodelet)
++PLUGINLIB_EXPORT_CLASS(hector_pose_estimation::PoseEstimationNodelet, nodelet::Nodelet)
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild
index 7cc3dd4e6490..284a8883bbab 100644
--- a/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild
+++ b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -26,3 +26,5 @@ RDEPEND="
"
# dev-ros/hector_timing
DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.3.0-pluginlib.patch )