summaryrefslogtreecommitdiff
path: root/dev-ros/message_to_tf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/message_to_tf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/message_to_tf')
-rw-r--r--dev-ros/message_to_tf/Manifest4
-rw-r--r--dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild24
-rw-r--r--dev-ros/message_to_tf/message_to_tf-9999.ebuild24
-rw-r--r--dev-ros/message_to_tf/metadata.xml11
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-ros/message_to_tf/Manifest b/dev-ros/message_to_tf/Manifest
new file mode 100644
index 000000000000..92e8ded9fa7b
--- /dev/null
+++ b/dev-ros/message_to_tf/Manifest
@@ -0,0 +1,4 @@
+DIST hector_localization-0.3.0.tar.gz 73656 BLAKE2B 8e895c760974f8707eb174b3b385f03f07f93f89b470d88140f1134a3cb9fb8e67e65a86484b702dbaed09e4d614f4c6759f1e08b536385f86ec15dc3db6a644 SHA512 5763a98247754b021631c894d44172d7c215d81f556760578f585febf2248da8dfcf10c6f1430cff47800778d39a79ab31a59916ad13c6d5ecf8a17eeac4e8df
+EBUILD message_to_tf-0.3.0.ebuild 618 BLAKE2B 186b7388b25bf2dae7144a79d0f57b38c6bcc7da12cc95ff774a6fb307f63975289e828c2ea93f5688d388e14e4a1f679097f215e4621b5c49611e9b7be67efd SHA512 f5a23da8ea1d7c371554b7b459497098ba42be625291773824729a046c4903c4d2bb97f8417d9d3267effa6774dfa4ab60c148d440e0b7b0ba16d9ca97823e25
+EBUILD message_to_tf-9999.ebuild 618 BLAKE2B 186b7388b25bf2dae7144a79d0f57b38c6bcc7da12cc95ff774a6fb307f63975289e828c2ea93f5688d388e14e4a1f679097f215e4621b5c49611e9b7be67efd SHA512 f5a23da8ea1d7c371554b7b459497098ba42be625291773824729a046c4903c4d2bb97f8417d9d3267effa6774dfa4ab60c148d440e0b7b0ba16d9ca97823e25
+MISC metadata.xml 354 BLAKE2B 8fa87680be83a7fc421afc00fa7e203bd512c42324cee5ce59f08a6acdfacdd09a8427e547982ccff17253589708a0556e51420188c3639ab638df4994e4edb7 SHA512 5efea6ff063bdb92ca5c0c45cbc4c9cc110d4ed800b8631259abdffb771abb183594d9e72920e0daf9948c909a69ab564b70fed83bb2a0a879d5712f3c608420
diff --git a/dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild b/dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild
new file mode 100644
index 000000000000..5b2da944b6a4
--- /dev/null
+++ b/dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Translates pose information from different kind of common_msgs message types to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/topic_tools
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/message_to_tf/message_to_tf-9999.ebuild b/dev-ros/message_to_tf/message_to_tf-9999.ebuild
new file mode 100644
index 000000000000..5b2da944b6a4
--- /dev/null
+++ b/dev-ros/message_to_tf/message_to_tf-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Translates pose information from different kind of common_msgs message types to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/topic_tools
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/message_to_tf/metadata.xml b/dev-ros/message_to_tf/metadata.xml
new file mode 100644
index 000000000000..ee6ea29b2d58
--- /dev/null
+++ b/dev-ros/message_to_tf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tu-darmstadt-ros-pkg/hector_localization</remote-id>
+ </upstream>
+</pkgmetadata>