summaryrefslogtreecommitdiff
path: root/dev-ros/move_base/move_base-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/move_base/move_base-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/move_base/move_base-9999.ebuild')
-rw-r--r--dev-ros/move_base/move_base-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/move_base/move_base-9999.ebuild b/dev-ros/move_base/move_base-9999.ebuild
new file mode 100644
index 000000000000..2a5ac378d7c6
--- /dev/null
+++ b/dev-ros/move_base/move_base-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Given a goal in the world, will attempt to reach it with a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.15.1
+ dev-ros/roscpp
+ dev-ros/pluginlib
+ dev-ros/actionlib
+ dev-ros/base_local_planner
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/tf
+ dev-ros/move_base_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"