summaryrefslogtreecommitdiff
path: root/dev-ros/pr2_msgs/pr2_msgs-1.12.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /dev-ros/pr2_msgs/pr2_msgs-1.12.4.ebuild
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'dev-ros/pr2_msgs/pr2_msgs-1.12.4.ebuild')
-rw-r--r--dev-ros/pr2_msgs/pr2_msgs-1.12.4.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/pr2_msgs/pr2_msgs-1.12.4.ebuild b/dev-ros/pr2_msgs/pr2_msgs-1.12.4.ebuild
new file mode 100644
index 000000000000..01b46e644d64
--- /dev/null
+++ b/dev-ros/pr2_msgs/pr2_msgs-1.12.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages for representing PR2 state, such as battery information and the PR2 fingertip sensors"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"