summaryrefslogtreecommitdiff
path: root/dev-ros/python_cmake_module
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/python_cmake_module
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/python_cmake_module')
-rw-r--r--dev-ros/python_cmake_module/Manifest4
-rw-r--r--dev-ros/python_cmake_module/metadata.xml11
-rw-r--r--dev-ros/python_cmake_module/python_cmake_module-0.8.0.ebuild54
-rw-r--r--dev-ros/python_cmake_module/python_cmake_module-9999.ebuild54
4 files changed, 123 insertions, 0 deletions
diff --git a/dev-ros/python_cmake_module/Manifest b/dev-ros/python_cmake_module/Manifest
new file mode 100644
index 000000000000..4345175ee119
--- /dev/null
+++ b/dev-ros/python_cmake_module/Manifest
@@ -0,0 +1,4 @@
+DIST python_cmake_module-0.8.0.tar.gz 7026 BLAKE2B 38946d2499ee2d2d6bbdc261453ca9b1d3d3743a5e7b5facd88ce6fc1cd310a475b9a388039ef3a1c6f1990d987b1e7e121bab8b2c993b6cd2034835f4430671 SHA512 8c19ea65c6848c5df1efdbb4134e410af00ffdc9e980f761b448eaee04259fd6faa511c2b7fa8ee1ba2a8c5e3bd0c4a20cc7cdeba534512592a2809cf64f3ab7
+EBUILD python_cmake_module-0.8.0.ebuild 1111 BLAKE2B d3db30003ddc6e0e41164e9788f6c17800950ac8d5e7c8fdda02c24cbe0586f4780c17ea3fcaeb9ae7234e48efd0830f128acc01a4d0d3b2146e650792e1ee51 SHA512 5afccb346a4bb4f5384983cb3e40e573a6301ef07616f283a50a4562601d02caca197386036b994fd956284e2d150d7b2491921c40a6d8506f7f75b47e620d61
+EBUILD python_cmake_module-9999.ebuild 1111 BLAKE2B d3db30003ddc6e0e41164e9788f6c17800950ac8d5e7c8fdda02c24cbe0586f4780c17ea3fcaeb9ae7234e48efd0830f128acc01a4d0d3b2146e650792e1ee51 SHA512 5afccb346a4bb4f5384983cb3e40e573a6301ef07616f283a50a4562601d02caca197386036b994fd956284e2d150d7b2491921c40a6d8506f7f75b47e620d61
+MISC metadata.xml 338 BLAKE2B 09f1c53f00178afd4738a502187b87c5df6d08de21ed2495715cbab52073b307ce335fa2b29e5c4d77d84def4edaa04efa37add566b8d9a7d40a122d44b0e769 SHA512 b1de856f11f458954837430045b05058912bde28badc8c7e9082a66d72e5ded51a5914acbb50adbada11ee123137d25dec76132b17d2ced01d4cea1e67ea30e0
diff --git a/dev-ros/python_cmake_module/metadata.xml b/dev-ros/python_cmake_module/metadata.xml
new file mode 100644
index 000000000000..d627aa8ccfee
--- /dev/null
+++ b/dev-ros/python_cmake_module/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros2/python_cmake_module</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/python_cmake_module/python_cmake_module-0.8.0.ebuild b/dev-ros/python_cmake_module/python_cmake_module-0.8.0.ebuild
new file mode 100644
index 000000000000..7dc30fbf51a0
--- /dev/null
+++ b/dev-ros/python_cmake_module/python_cmake_module-0.8.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="python_cmake_module"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ros2/python_cmake_module"
+ SRC_URI=""
+ S=${WORKDIR}/${P}
+else
+ SRC_URI="https://github.com/ros2/python_cmake_module/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}"
+fi
+
+DESCRIPTION="CMake module with extra functionality for Python"
+HOMEPAGE="https://github.com/ros2/python_cmake_module"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ test? (
+ dev-ros/ament_lint_auto
+ )
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}
diff --git a/dev-ros/python_cmake_module/python_cmake_module-9999.ebuild b/dev-ros/python_cmake_module/python_cmake_module-9999.ebuild
new file mode 100644
index 000000000000..7dc30fbf51a0
--- /dev/null
+++ b/dev-ros/python_cmake_module/python_cmake_module-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="python_cmake_module"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ros2/python_cmake_module"
+ SRC_URI=""
+ S=${WORKDIR}/${P}
+else
+ SRC_URI="https://github.com/ros2/python_cmake_module/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}"
+fi
+
+DESCRIPTION="CMake module with extra functionality for Python"
+HOMEPAGE="https://github.com/ros2/python_cmake_module"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ test? (
+ dev-ros/ament_lint_auto
+ )
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}