summaryrefslogtreecommitdiff
path: root/dev-ros/python_cmake_module
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-ros/python_cmake_module
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-ros/python_cmake_module')
-rw-r--r--dev-ros/python_cmake_module/Manifest4
-rw-r--r--dev-ros/python_cmake_module/python_cmake_module-0.8.1.ebuild13
-rw-r--r--dev-ros/python_cmake_module/python_cmake_module-9999.ebuild13
3 files changed, 6 insertions, 24 deletions
diff --git a/dev-ros/python_cmake_module/Manifest b/dev-ros/python_cmake_module/Manifest
index c097bf120dbb..5e3ed7a79e0a 100644
--- a/dev-ros/python_cmake_module/Manifest
+++ b/dev-ros/python_cmake_module/Manifest
@@ -1,4 +1,4 @@
DIST python_cmake_module-0.8.1.tar.gz 7047 BLAKE2B 79f6259913d42381443f3d93d48f67fb325abf423baf054465d83f641ca40f5bfad0acab0f19560968a280eaacecf56df253c90688d75144e25e27e28f3646b0 SHA512 f513031c9d0bbd5d05a1711074287a5ffd0c30be79d2f4849599ff539584f950c2e7c2322763358c8a1ac266da325f40fe9cd4d3a127cd6a9e4dfd83a3e4149c
-EBUILD python_cmake_module-0.8.1.ebuild 1113 BLAKE2B e7d8580459b468295c8a801b74b8079c7987ec0cde60d10761765a49bba31d6fef0945760048dbb6762fee722b94d9f1553a5fb5e92e2a7261f8a3e42a61d782 SHA512 09d97095ff454ea8f046b4dc6afddb65eae195508b1bfce94f83aa74554afac255d7e44906559b73df7aee23a3612661d88706d23bc948e8af8800c3c806db00
-EBUILD python_cmake_module-9999.ebuild 1113 BLAKE2B e7d8580459b468295c8a801b74b8079c7987ec0cde60d10761765a49bba31d6fef0945760048dbb6762fee722b94d9f1553a5fb5e92e2a7261f8a3e42a61d782 SHA512 09d97095ff454ea8f046b4dc6afddb65eae195508b1bfce94f83aa74554afac255d7e44906559b73df7aee23a3612661d88706d23bc948e8af8800c3c806db00
+EBUILD python_cmake_module-0.8.1.ebuild 985 BLAKE2B 27cecad104beb11ffed14b394b8a8ee2f25fc27fa628904cd0db6bc80b0854be1178c465db095c6e4d1e57f5067e35eccaf75cf5177ae8e43026a403753e39ec SHA512 216e5845f2896bd4dccc0f1c20d0272ee755e5ab6fbc2810dd5ee8e985e202d812d2bc12e3a20f7057d9106e6f0cf8f8d3b5c9a01bfdebbaa32acb631f738b05
+EBUILD python_cmake_module-9999.ebuild 985 BLAKE2B 27cecad104beb11ffed14b394b8a8ee2f25fc27fa628904cd0db6bc80b0854be1178c465db095c6e4d1e57f5067e35eccaf75cf5177ae8e43026a403753e39ec SHA512 216e5845f2896bd4dccc0f1c20d0272ee755e5ab6fbc2810dd5ee8e985e202d812d2bc12e3a20f7057d9106e6f0cf8f8d3b5c9a01bfdebbaa32acb631f738b05
MISC metadata.xml 339 BLAKE2B 377b2b39e6e34169034061e193a85f733223ab4016b86ebe047622d579eb7981ea80f50e1210a048c53df099f1d529312287c69eeedd0726d0f88ad217f1208a SHA512 be0c139a5d989a28bba3fe868d5c5700abcc802e1d976d732eb90479393937b09f6cdce8d542bdb587d1699a2e55b741ccef508087c1c9476f66d1ca6a83f54b
diff --git a/dev-ros/python_cmake_module/python_cmake_module-0.8.1.ebuild b/dev-ros/python_cmake_module/python_cmake_module-0.8.1.ebuild
index 150095c180f0..a94a808de7ac 100644
--- a/dev-ros/python_cmake_module/python_cmake_module-0.8.1.ebuild
+++ b/dev-ros/python_cmake_module/python_cmake_module-0.8.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-any-r1
@@ -11,11 +11,10 @@ ROS_PN="python_cmake_module"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ros2/python_cmake_module"
- SRC_URI=""
- S=${WORKDIR}/${P}
else
SRC_URI="https://github.com/ros2/python_cmake_module/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="CMake module with extra functionality for Python"
@@ -23,17 +22,9 @@ HOMEPAGE="https://github.com/ros2/python_cmake_module"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="
-"
-DEPEND="${RDEPEND}"
BDEPEND="
$(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
test? (
diff --git a/dev-ros/python_cmake_module/python_cmake_module-9999.ebuild b/dev-ros/python_cmake_module/python_cmake_module-9999.ebuild
index 150095c180f0..a94a808de7ac 100644
--- a/dev-ros/python_cmake_module/python_cmake_module-9999.ebuild
+++ b/dev-ros/python_cmake_module/python_cmake_module-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-any-r1
@@ -11,11 +11,10 @@ ROS_PN="python_cmake_module"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ros2/python_cmake_module"
- SRC_URI=""
- S=${WORKDIR}/${P}
else
SRC_URI="https://github.com/ros2/python_cmake_module/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="CMake module with extra functionality for Python"
@@ -23,17 +22,9 @@ HOMEPAGE="https://github.com/ros2/python_cmake_module"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="
-"
-DEPEND="${RDEPEND}"
BDEPEND="
$(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
test? (