summaryrefslogtreecommitdiff
path: root/dev-ros/robot_state_publisher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
commit6957f5c65b02bba533954eabc0b62f5de36be206 (patch)
tree21d8ab8f61dffd9cccc82d0badb68982516a6855 /dev-ros/robot_state_publisher
parente91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (diff)
gentoo resync : 10.04.2018
Diffstat (limited to 'dev-ros/robot_state_publisher')
-rw-r--r--dev-ros/robot_state_publisher/Manifest4
-rw-r--r--dev-ros/robot_state_publisher/robot_state_publisher-1.13.6-r1.ebuild33
-rw-r--r--dev-ros/robot_state_publisher/robot_state_publisher-9999.ebuild7
3 files changed, 39 insertions, 5 deletions
diff --git a/dev-ros/robot_state_publisher/Manifest b/dev-ros/robot_state_publisher/Manifest
index a1d2c16a562a..d4ab37b81f41 100644
--- a/dev-ros/robot_state_publisher/Manifest
+++ b/dev-ros/robot_state_publisher/Manifest
@@ -1,4 +1,6 @@
DIST robot_state_publisher-1.13.5.tar.gz 25346 BLAKE2B bdc7ed15178cdd8a8571796236b5273666f58486b831374254b45b79549d8b224097cb78c4585cb136f74bd4fee8309dfdef6dbaa03038acc126b35a4e2899dc SHA512 2ce97e35a64f9c6f8539780d2dabf416906da8144b579b07214b55e935aec3105f2087c90796ceb896f8766c46c2c2b72aaf9fdc4cfc80dd1b3f06b477acf778
+DIST robot_state_publisher-1.13.6.tar.gz 25885 BLAKE2B 0d673ef6cce53ff66a522de02ddeb93876d168a65cf102de2c0384f69911d9dfedf1cadba67e7251ed0ccdc7bf07b545c2ded5620419a970bbcf6fb63c9fcd15 SHA512 c0dbdd9149a1b308c29de1509641691d488aa0cd6b325d1245cbb16b537bbd3abf0c5e85ecd1c24a78117b6e45a833a45769c6619a22bfc7a1f5f7709071b21a
EBUILD robot_state_publisher-1.13.5.ebuild 671 BLAKE2B 9bd628fdbb6241568cae65ec421bc0191cfe6e9ad8567203be75c27583b93a36636878b3a964c944f407718522b58bcbd1b68ce330e28b771d48db9b7e861061 SHA512 e2af853e68989e5b0101dd8ec30d919cd72703d6c8a3d42e70fa8da76662af45dacc4f8dea6b0d055d98c6ad3a44e36e747e194cd40f7802b2224cafcd757298
-EBUILD robot_state_publisher-9999.ebuild 671 BLAKE2B 9bd628fdbb6241568cae65ec421bc0191cfe6e9ad8567203be75c27583b93a36636878b3a964c944f407718522b58bcbd1b68ce330e28b771d48db9b7e861061 SHA512 e2af853e68989e5b0101dd8ec30d919cd72703d6c8a3d42e70fa8da76662af45dacc4f8dea6b0d055d98c6ad3a44e36e747e194cd40f7802b2224cafcd757298
+EBUILD robot_state_publisher-1.13.6-r1.ebuild 672 BLAKE2B d05f35eae1952fd234adbd65b9b5786140abea5d38d6518206f92afc4393b4e74335dccf27081b1fd2f9c9167753cdf6744fc1009f8dd1ee68d81e141da6788c SHA512 54728b5872ed76175adffea5a37a004ee0fb708732c416365ac659b923b0aac725657fdfaa7a52608f6052b3929c7e359136493a3bba1a6097283fc97cc71538
+EBUILD robot_state_publisher-9999.ebuild 672 BLAKE2B d05f35eae1952fd234adbd65b9b5786140abea5d38d6518206f92afc4393b4e74335dccf27081b1fd2f9c9167753cdf6744fc1009f8dd1ee68d81e141da6788c SHA512 54728b5872ed76175adffea5a37a004ee0fb708732c416365ac659b923b0aac725657fdfaa7a52608f6052b3929c7e359136493a3bba1a6097283fc97cc71538
MISC metadata.xml 339 BLAKE2B c76bafb73ba3f7049a2c6914ffe15e5df15da5f12fb10dd8b2fd6d5b2dba00007a86c35ca2cf9a93cb6d1425d4c87afe3161571b75a0c81754b5d0aa92442bd9 SHA512 c6c382ed3b649d5e464df1c13fb5f6798f4005fc34cb5f8b5c5062fa5885bc2a2ef6c543bc85a734e0f9ebd90adad0177de84c801dafee9e4cffe51e052a86f7
diff --git a/dev-ros/robot_state_publisher/robot_state_publisher-1.13.6-r1.ebuild b/dev-ros/robot_state_publisher/robot_state_publisher-1.13.6-r1.ebuild
new file mode 100644
index 000000000000..760d6df668f3
--- /dev/null
+++ b/dev-ros/robot_state_publisher/robot_state_publisher-1.13.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_state_publisher"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Package for publishing the state of a robot to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/kdl_parser
+ dev-cpp/eigen:3
+ sci-libs/orocos_kdl:=
+ dev-ros/roscpp
+ dev-ros/rosconsole
+ dev-ros/rostime
+ dev-ros/tf2_ros
+ dev-ros/tf2_kdl
+ dev-ros/kdl_conversions
+ dev-ros/sensor_msgs
+ dev-ros/tf
+ dev-ros/urdf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_USEDEP}] )
+"
diff --git a/dev-ros/robot_state_publisher/robot_state_publisher-9999.ebuild b/dev-ros/robot_state_publisher/robot_state_publisher-9999.ebuild
index 508dcb8c0b07..760d6df668f3 100644
--- a/dev-ros/robot_state_publisher/robot_state_publisher-9999.ebuild
+++ b/dev-ros/robot_state_publisher/robot_state_publisher-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,7 +16,7 @@ IUSE=""
RDEPEND="
dev-ros/kdl_parser
dev-cpp/eigen:3
- sci-libs/orocos_kdl
+ sci-libs/orocos_kdl:=
dev-ros/roscpp
dev-ros/rosconsole
dev-ros/rostime
@@ -29,6 +29,5 @@ RDEPEND="
dev-libs/boost:=
"
DEPEND="${RDEPEND}
- dev-ros/rostest[${PYTHON_USEDEP}]
- test? ( dev-cpp/gtest )
+ test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_USEDEP}] )
"