summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_plot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/rqt_plot
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/rqt_plot')
-rw-r--r--dev-ros/rqt_plot/Manifest4
-rw-r--r--dev-ros/rqt_plot/metadata.xml11
-rw-r--r--dev-ros/rqt_plot/rqt_plot-0.4.8.ebuild32
-rw-r--r--dev-ros/rqt_plot/rqt_plot-9999.ebuild32
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-ros/rqt_plot/Manifest b/dev-ros/rqt_plot/Manifest
new file mode 100644
index 000000000000..2b911db7dc31
--- /dev/null
+++ b/dev-ros/rqt_plot/Manifest
@@ -0,0 +1,4 @@
+DIST rqt_plot-0.4.8.tar.gz 19153 BLAKE2B 300ab2d7b27dddcad1403bd10aae46406b95aa00f80ac55bd479241deeef746720db5f03dc62957500774ddaa97379902441363c8e590d34c032a25f8d6ebbf9 SHA512 c06a5c0990ee071c20f278c44456404b9f9b7e211b16aa5d670ccffcbf6cd69f24d2c30e930c99c97b4288b996138a73243f877656dcfcf960c4684df3deaf5d
+EBUILD rqt_plot-0.4.8.ebuild 897 BLAKE2B 5e65e7f437cb9e918469d723cc4ac270cacb88c487ca85890d31848043f81ec2650e48d9540af6d93416eb6acd6b5f67d2b2fa251b192b2ef22c6692c5f8d507 SHA512 32ab396cd10f1ff962967e04f3d78de91c8cc335bf2b53fccc8459cc3bb47da24e91e9ec168de2a35c74c778f80f024627bd70d61265f07082f22b81bcd7ec4e
+EBUILD rqt_plot-9999.ebuild 897 BLAKE2B 5e65e7f437cb9e918469d723cc4ac270cacb88c487ca85890d31848043f81ec2650e48d9540af6d93416eb6acd6b5f67d2b2fa251b192b2ef22c6692c5f8d507 SHA512 32ab396cd10f1ff962967e04f3d78de91c8cc335bf2b53fccc8459cc3bb47da24e91e9ec168de2a35c74c778f80f024627bd70d61265f07082f22b81bcd7ec4e
+MISC metadata.xml 340 BLAKE2B ee1e844a5600f4b8d81b5fcba490547da1428d73df295887987360255cce0c90530dd36f6d6cc3b49c7348e1c8f59196c8d812f18b211aa0ae1afc6437058c99 SHA512 50ba9ca4bdbaea86622fdf825491641172ee07f413fed602f8aad0f5f8e3b0dcfdbb88100863a53b9d550dd9d3b038462873b06b8a3012280a57ffe3b35e3421
diff --git a/dev-ros/rqt_plot/metadata.xml b/dev-ros/rqt_plot/metadata.xml
new file mode 100644
index 000000000000..cd25fa3cc4c6
--- /dev/null
+++ b/dev-ros/rqt_plot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-visualization/rqt_plot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rqt_plot/rqt_plot-0.4.8.ebuild b/dev-ros/rqt_plot/rqt_plot-0.4.8.ebuild
new file mode 100644
index 000000000000..845689ab2731
--- /dev/null
+++ b/dev-ros/rqt_plot/rqt_plot-0.4.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_plot"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin visualizing numeric values in a 2D plot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pyqtgraph[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_plot/rqt_plot-9999.ebuild b/dev-ros/rqt_plot/rqt_plot-9999.ebuild
new file mode 100644
index 000000000000..845689ab2731
--- /dev/null
+++ b/dev-ros/rqt_plot/rqt_plot-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_plot"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin visualizing numeric values in a 2D plot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pyqtgraph[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"