summaryrefslogtreecommitdiff
path: root/dev-ros/sensor_msgs/sensor_msgs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/sensor_msgs/sensor_msgs-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/sensor_msgs/sensor_msgs-9999.ebuild')
-rw-r--r--dev-ros/sensor_msgs/sensor_msgs-9999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-ros/sensor_msgs/sensor_msgs-9999.ebuild b/dev-ros/sensor_msgs/sensor_msgs-9999.ebuild
index 99a3cc4151ad..aff165c07cee 100644
--- a/dev-ros/sensor_msgs/sensor_msgs-9999.ebuild
+++ b/dev-ros/sensor_msgs/sensor_msgs-9999.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
CATKIN_HAS_MESSAGES=yes
ROS_REPO_URI="https://github.com/ros/common_msgs"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
ROS_SUBDIR=${PN}
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
inherit ros-catkin
-DESCRIPTION="Messages for commonly used sensors, including cameras and scanning laser rangefinders"
+DESCRIPTION="Messages for commonly used sensors: cameras and scanning laser rangefinders"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
- test? ( dev-cpp/gtest dev-ros/rosunit[${PYTHON_USEDEP}] )
+ test? ( dev-cpp/gtest dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}] )
"
RDEPEND="${RDEPEND}"