summaryrefslogtreecommitdiff
path: root/dev-ros/smach
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/smach
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/smach')
-rw-r--r--dev-ros/smach/Manifest4
-rw-r--r--dev-ros/smach/metadata.xml11
-rw-r--r--dev-ros/smach/smach-2.0.1.ebuild19
-rw-r--r--dev-ros/smach/smach-9999.ebuild19
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-ros/smach/Manifest b/dev-ros/smach/Manifest
new file mode 100644
index 000000000000..da2c3c62f28e
--- /dev/null
+++ b/dev-ros/smach/Manifest
@@ -0,0 +1,4 @@
+DIST executive_smach-2.0.1.tar.gz 42032 BLAKE2B 9271515a67436cd4873d4df5d1abae586af9ae856f9c90904732382e4824bd0bb23c820cd761017532604cde4c7c07ed4a98465b3267319dbc00b61b2d028dea SHA512 88be9ad6a0ec1e82e1592d26621fbbfe24e45640266f369cd03f192649bfd865e5a4ea576cf665161c0f89805e67b38b8b64b62a054ca1e217b99d8284f3b32a
+EBUILD smach-2.0.1.ebuild 427 BLAKE2B 7fe1e83856d97f0541767052121678f4fa5149b05f57d01ea124b819ba2f9385a26e41e35d01da2edcc1bc8077308c7a4b743d426ee0302258674eb69fb36827 SHA512 d31e236924bd3ce279c9e99e3a7a486140982b2ff6e0a7187c7b12a65998a7d31066279334b3fb24a53e3890c5c920bbbf6a08edd6b608521b564d10e480bcdf
+EBUILD smach-9999.ebuild 427 BLAKE2B 7fe1e83856d97f0541767052121678f4fa5149b05f57d01ea124b819ba2f9385a26e41e35d01da2edcc1bc8077308c7a4b743d426ee0302258674eb69fb36827 SHA512 d31e236924bd3ce279c9e99e3a7a486140982b2ff6e0a7187c7b12a65998a7d31066279334b3fb24a53e3890c5c920bbbf6a08edd6b608521b564d10e480bcdf
+MISC metadata.xml 333 BLAKE2B 9464368a741c4058fe2563c0a8a575e29bf8a74c43430a6c6f7be286419f675a560290c95d2afdf6e942843e233680e86886237a43ebe8d36136ebd36b4feb04 SHA512 c5e649958133658717bd4d1723953187a4c9626c7a1143fa784bc10ef533165bcb386248a42e20e9c1f7de4147e34c5a09f1009c5c65a78e2ed8fa0ccfc56165
diff --git a/dev-ros/smach/metadata.xml b/dev-ros/smach/metadata.xml
new file mode 100644
index 000000000000..d2fce8b37504
--- /dev/null
+++ b/dev-ros/smach/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/executive_smach</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/smach/smach-2.0.1.ebuild b/dev-ros/smach/smach-2.0.1.ebuild
new file mode 100644
index 000000000000..8e7347a0da5d
--- /dev/null
+++ b/dev-ros/smach/smach-2.0.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Task-level architecture for rapidly creating complex robot behavior"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/smach/smach-9999.ebuild b/dev-ros/smach/smach-9999.ebuild
new file mode 100644
index 000000000000..8e7347a0da5d
--- /dev/null
+++ b/dev-ros/smach/smach-9999.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Task-level architecture for rapidly creating complex robot behavior"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"