summaryrefslogtreecommitdiff
path: root/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-9999.ebuild')
-rw-r--r--dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-9999.ebuild b/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-9999.ebuild
index cabd94dbe35a..fcaf935a3f4e 100644
--- a/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-9999.ebuild
+++ b/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/diagnostics"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
@@ -23,3 +23,9 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/gcc6.patch" )
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH="${BUILD_DIR}/devel/:${CATKIN_PREFIX_PATH}"
+ ros-catkin_src_test
+}