summaryrefslogtreecommitdiff
path: root/dev-ros/test_rosbag_storage/test_rosbag_storage-1.15.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-ros/test_rosbag_storage/test_rosbag_storage-1.15.10.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-ros/test_rosbag_storage/test_rosbag_storage-1.15.10.ebuild')
-rw-r--r--dev-ros/test_rosbag_storage/test_rosbag_storage-1.15.10.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/test_rosbag_storage/test_rosbag_storage-1.15.10.ebuild b/dev-ros/test_rosbag_storage/test_rosbag_storage-1.15.10.ebuild
new file mode 100644
index 000000000000..56f714211def
--- /dev/null
+++ b/dev-ros/test_rosbag_storage/test_rosbag_storage-1.15.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosbag_storage"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rosbag_storage
+ dev-ros/rosbag
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ test? ( dev-cpp/gtest )"