summaryrefslogtreecommitdiff
path: root/dev-ros/test_rospy/test_rospy-1.15.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ros/test_rospy/test_rospy-1.15.14.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ros/test_rospy/test_rospy-1.15.14.ebuild')
-rw-r--r--dev-ros/test_rospy/test_rospy-1.15.14.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/test_rospy-1.15.14.ebuild b/dev-ros/test_rospy/test_rospy-1.15.14.ebuild
new file mode 100644
index 000000000000..77c19fe38c01
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.15.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_SINGLE_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
+ test? (
+ $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/psutil[\${PYTHON_USEDEP}]")
+ )"