summaryrefslogtreecommitdiff
path: root/dev-ros/test_rospy/test_rospy-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/test_rospy/test_rospy-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/test_rospy/test_rospy-9999.ebuild')
-rw-r--r--dev-ros/test_rospy/test_rospy-9999.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/dev-ros/test_rospy/test_rospy-9999.ebuild b/dev-ros/test_rospy/test_rospy-9999.ebuild
index a87a452ada24..5b429c7f5335 100644
--- a/dev-ros/test_rospy/test_rospy-9999.ebuild
+++ b/dev-ros/test_rospy/test_rospy-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/ros_comm"
KEYWORDS="~amd64 ~arm"
@@ -9,8 +9,6 @@ ROS_SUBDIR=test/${PN}
CATKIN_HAS_MESSAGES=yes
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
-PYTHON_COMPAT=( python2_7 )
-
inherit ros-catkin
DESCRIPTION="Unit tests for rospy"
@@ -20,14 +18,16 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_SINGLE_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
test? (
- dev-python/numpy[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
dev-ros/rosbuild
- dev-ros/rosgraph[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/psutil[\${PYTHON_USEDEP}]")
)"