summaryrefslogtreecommitdiff
path: root/dev-ros/test_tf2/test_tf2-0.7.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-25 15:53:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-25 15:53:58 +0100
commitb8c48743664466ac0f638f0949fd78bfb9f5eae6 (patch)
treedd60615a286df950811f8267c0631e1fd97eac58 /dev-ros/test_tf2/test_tf2-0.7.6.ebuild
parentcf9065b9fe1f8c33a6e488fce1ee75d893cd351f (diff)
gentoo auto-resync : 25:10:2022 - 15:53:58
Diffstat (limited to 'dev-ros/test_tf2/test_tf2-0.7.6.ebuild')
-rw-r--r--dev-ros/test_tf2/test_tf2-0.7.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/test_tf2/test_tf2-0.7.6.ebuild b/dev-ros/test_tf2/test_tf2-0.7.6.ebuild
new file mode 100644
index 000000000000..3482393f54a3
--- /dev/null
+++ b/dev-ros/test_tf2/test_tf2-0.7.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 unit tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_bullet
+ dev-ros/tf2_eigen
+ dev-ros/tf2_ros[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_kdl[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_msgs
+ dev-ros/rosbash
+ sci-libs/orocos_kdl
+ $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
+ dev-libs/boost:=
+ dev-cpp/gtest
+"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )