summaryrefslogtreecommitdiff
path: root/dev-ros/tf2/tf2-0.7.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-25 15:53:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-25 15:53:58 +0100
commitb8c48743664466ac0f638f0949fd78bfb9f5eae6 (patch)
treedd60615a286df950811f8267c0631e1fd97eac58 /dev-ros/tf2/tf2-0.7.6.ebuild
parentcf9065b9fe1f8c33a6e488fce1ee75d893cd351f (diff)
gentoo auto-resync : 25:10:2022 - 15:53:58
Diffstat (limited to 'dev-ros/tf2/tf2-0.7.6.ebuild')
-rw-r--r--dev-ros/tf2/tf2-0.7.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/tf2/tf2-0.7.6.ebuild b/dev-ros/tf2/tf2-0.7.6.ebuild
new file mode 100644
index 000000000000..401a57c0c955
--- /dev/null
+++ b/dev-ros/tf2/tf2-0.7.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="The second generation Transform Library in ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/console_bridge:=
+ dev-ros/rostime
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? ( dev-ros/roscpp dev-cpp/gtest )
+"