summaryrefslogtreecommitdiff
path: root/dev-ros/theora_image_transport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/theora_image_transport
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/theora_image_transport')
-rw-r--r--dev-ros/theora_image_transport/Manifest4
-rw-r--r--dev-ros/theora_image_transport/metadata.xml11
-rw-r--r--dev-ros/theora_image_transport/theora_image_transport-1.9.5-r1.ebuild33
-rw-r--r--dev-ros/theora_image_transport/theora_image_transport-9999.ebuild33
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-ros/theora_image_transport/Manifest b/dev-ros/theora_image_transport/Manifest
new file mode 100644
index 000000000000..e70a6702c988
--- /dev/null
+++ b/dev-ros/theora_image_transport/Manifest
@@ -0,0 +1,4 @@
+DIST image_transport_plugins-1.9.5.tar.gz 26268 BLAKE2B 2d7e71f891bc3ae548193a9671fb10fb4dc6c7a24fda0c0dc52d75d43793d55e35da37155496740624e4ebe34fcf0e8d3926345ca1581fa521096c01b773f551 SHA512 54f459719a386f028578889f9b88b8b080f495d75899cee6c8bfb58204970fb2395b2a8da70034eb391ba62f4ce462cb89b97bcdc576a177444613076b5ed02c
+EBUILD theora_image_transport-1.9.5-r1.ebuild 789 BLAKE2B b282ad8b57e9ed7dded23494a3810fd77a2c90ab710dadfad714d82c2c51d06526429ceb40ab2d521232b6d9599d12a844276be70ddcbe20860db7e43fed23b8 SHA512 13bc08389db9e05dfe415bf3a7e29346ed62cdd19e33cba9041eb2ada68406c243877df12279b487ba65f9f94de9dcb0e4dcc1874313b971f89cb8919c25d0c5
+EBUILD theora_image_transport-9999.ebuild 789 BLAKE2B b282ad8b57e9ed7dded23494a3810fd77a2c90ab710dadfad714d82c2c51d06526429ceb40ab2d521232b6d9599d12a844276be70ddcbe20860db7e43fed23b8 SHA512 13bc08389db9e05dfe415bf3a7e29346ed62cdd19e33cba9041eb2ada68406c243877df12279b487ba65f9f94de9dcb0e4dcc1874313b971f89cb8919c25d0c5
+MISC metadata.xml 352 BLAKE2B d741d3235de6a630917b5785819ea9a3b13d8602bc5fd27b9fb8d4cea1df216fb64eaa0fd2fee5c5f11012a823311155331e2ae65af23874322679dc57bc32a9 SHA512 855c756eea98c52acb020fb394646008db35b41b864a0983f67bbf07ffce658d394c0de13d6622286770e4aa4152b74f2f6028c575b11b66233431d1fffa0347
diff --git a/dev-ros/theora_image_transport/metadata.xml b/dev-ros/theora_image_transport/metadata.xml
new file mode 100644
index 000000000000..feed05c03f5b
--- /dev/null
+++ b/dev-ros/theora_image_transport/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/image_transport_plugins</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/theora_image_transport/theora_image_transport-1.9.5-r1.ebuild b/dev-ros/theora_image_transport/theora_image_transport-1.9.5-r1.ebuild
new file mode 100644
index 000000000000..a13838696800
--- /dev/null
+++ b/dev-ros/theora_image_transport/theora_image_transport-1.9.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending an image stream encoded with the Theora codec"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_transport
+ media-libs/opencv
+ dev-ros/rosbag
+ dev-ros/pluginlib
+ media-libs/libogg
+ media-libs/libtheora[encode]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/dev-ros/theora_image_transport/theora_image_transport-9999.ebuild b/dev-ros/theora_image_transport/theora_image_transport-9999.ebuild
new file mode 100644
index 000000000000..a13838696800
--- /dev/null
+++ b/dev-ros/theora_image_transport/theora_image_transport-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending an image stream encoded with the Theora codec"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_transport
+ media-libs/opencv
+ dev-ros/rosbag
+ dev-ros/pluginlib
+ media-libs/libogg
+ media-libs/libtheora[encode]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"