summaryrefslogtreecommitdiff
path: root/dev-ros/unique_id/unique_id-1.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/unique_id/unique_id-1.0.6.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/unique_id/unique_id-1.0.6.ebuild')
-rw-r--r--dev-ros/unique_id/unique_id-1.0.6.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/dev-ros/unique_id/unique_id-1.0.6.ebuild b/dev-ros/unique_id/unique_id-1.0.6.ebuild
index 7ff69d0fac63..32432dfa5632 100644
--- a/dev-ros/unique_id/unique_id-1.0.6.ebuild
+++ b/dev-ros/unique_id/unique_id-1.0.6.ebuild
@@ -16,9 +16,19 @@ IUSE=""
RDEPEND="
dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
dev-ros/roscpp
"
DEPEND="${RDEPEND}
dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"
+ test? (
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
+PATCHES=( "${FILESDIR}/tests.patch" )
+
+src_test() {
+ # Those tests fail and are commented as undefined behavior in the code
+ export GTEST_FILTER='-BoostUUID.fromUrnString:BoostUUID.fromTooLongString:BoostUUID2.fromUrnString:BoostUUID2.fromTooLongString'
+ ros-catkin_src_test
+}