summaryrefslogtreecommitdiff
path: root/dev-ruby/GeoRuby
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/GeoRuby
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/GeoRuby')
-rw-r--r--dev-ruby/GeoRuby/GeoRuby-2.5.2.ebuild32
-rw-r--r--dev-ruby/GeoRuby/Manifest3
-rw-r--r--dev-ruby/GeoRuby/metadata.xml15
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/GeoRuby/GeoRuby-2.5.2.ebuild b/dev-ruby/GeoRuby/GeoRuby-2.5.2.ebuild
new file mode 100644
index 000000000000..77797b0c6def
--- /dev/null
+++ b/dev-ruby/GeoRuby/GeoRuby-2.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_NAME="georuby"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby data holder for OGC Simple Features"
+HOMEPAGE="https://github.com/nofxx/georuby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid specs that are also failing in upstream Travis.
+ rm spec/geo_ruby/shp4r/shp_spec.rb || die
+}
+
+ruby_add_bdepend "test? ( dev-ruby/dbf
+ dev-ruby/nokogiri )"
diff --git a/dev-ruby/GeoRuby/Manifest b/dev-ruby/GeoRuby/Manifest
new file mode 100644
index 000000000000..c08c83cce448
--- /dev/null
+++ b/dev-ruby/GeoRuby/Manifest
@@ -0,0 +1,3 @@
+DIST georuby-2.5.2.gem 211456 BLAKE2B 67340729118cfb64d78a0ac3e98a6e29414ba0ca111c8a9e608486803c4c1da51e99e06b9ac1abfba0b3781d330ad83e09b72cb5d643d32fc47ce35307045a17 SHA512 f65aca747ff2615ce2cecf0d3a9fa8728b362f211da0433b075e5abd95644daa8d5d8a6e19b051b8e2b78d55e819f07b19b2dfcb95f26f3d678c698fd7126f3f
+EBUILD GeoRuby-2.5.2.ebuild 640 BLAKE2B 28c57de526deb535aec38995493a687cb98c0c2022bb9b9f5af6579b53e1bf4441c1253b95faed101109397f20ea439c51d5f05252fda9da239e57ee2c9f8015 SHA512 53a64bbef3169c50ddb953abc006f6d408fcbdb852594dd39b6e1686d89f8fb4b5b5fd5f3da8a5a13bf497d48403f08fba416aca682cb2d0f1b5f022fb723d16
+MISC metadata.xml 475 BLAKE2B 61cd7a83f8ed2294338504f60c03e01e7144d58825db4732c207531fc78b34929bec9fc5459c4ab1458a0fc95ab97e07d1abe09b7eb5a54f867b214d9fbcc24d SHA512 d77d215e43f829b563daf62e06a06864e6e691784867227e6fc24726f5b6ba5238e356971c24bb1d1ccb5555fa65342da6530c9111a304552111a4deddc46111
diff --git a/dev-ruby/GeoRuby/metadata.xml b/dev-ruby/GeoRuby/metadata.xml
new file mode 100644
index 000000000000..06d6ccfca0a4
--- /dev/null
+++ b/dev-ruby/GeoRuby/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nofxx/georuby</remote-id>
+ </upstream>
+</pkgmetadata>