summaryrefslogtreecommitdiff
path: root/dev-ruby/acme-client/acme-client-2.0.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-19 20:08:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-19 20:08:27 +0000
commit2b2f431a0021b4787ca3c028cefb30ad81347778 (patch)
tree951e0155f53027c8fd29eaba26df4f08292668d5 /dev-ruby/acme-client/acme-client-2.0.16.ebuild
parentd725480af7cbc67d784e5d96f973fa41e9030123 (diff)
gentoo auto-resync : 19:01:2024 - 20:08:27
Diffstat (limited to 'dev-ruby/acme-client/acme-client-2.0.16.ebuild')
-rw-r--r--dev-ruby/acme-client/acme-client-2.0.16.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/acme-client/acme-client-2.0.16.ebuild b/dev-ruby/acme-client/acme-client-2.0.16.ebuild
new file mode 100644
index 000000000000..41f5c210bbbe
--- /dev/null
+++ b/dev-ruby/acme-client/acme-client-2.0.16.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="acme-client.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby client for the letsencrypt's ACME protocol"
+HOMEPAGE="https://github.com/unixcharles/acme-client"
+SRC_URI="https://github.com/unixcharles/acme-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_rdepend "
+ dev-ruby/faraday:2
+ dev-ruby/faraday-retry:2
+"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/vcr-2.9.3
+ >=dev-ruby/webmock-3.8:3
+)"
+
+all_ruby_prepare() {
+ # Avoid dependency on git
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e '3igem "faraday", "~> 2.0"' spec/spec_helper.rb || die
+}