summaryrefslogtreecommitdiff
path: root/dev-ruby/acme-client/acme-client-2.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-ruby/acme-client/acme-client-2.0.6.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-ruby/acme-client/acme-client-2.0.6.ebuild')
-rw-r--r--dev-ruby/acme-client/acme-client-2.0.6.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-ruby/acme-client/acme-client-2.0.6.ebuild b/dev-ruby/acme-client/acme-client-2.0.6.ebuild
deleted file mode 100644
index 964ca35b2327..000000000000
--- a/dev-ruby/acme-client/acme-client-2.0.6.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_GEMSPEC="acme-client.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby client for the letsencrypt's ACME protocol."
-HOMEPAGE="https://github.com/unixcharles/acme-client"
-SRC_URI="https://github.com/unixcharles/acme-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/faraday-0.17:0"
-
-ruby_add_bdepend "test? (
- >=dev-ruby/vcr-2.9.3
- >=dev-ruby/webmock-3.8:3
-)"
-
-all_ruby_prepare() {
- # Skip failing test where incorrect der value is retrieved, may be openssl 1.1.x related.
- sed -i -e '/assigns the public key/apending' spec/certificate_request_spec.rb || die
-
- # Avoid dependency on git
- sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}