summaryrefslogtreecommitdiff
path: root/dev-ruby/actionpack-xml_parser/actionpack-xml_parser-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/actionpack-xml_parser/actionpack-xml_parser-1.0.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/actionpack-xml_parser/actionpack-xml_parser-1.0.2.ebuild')
-rw-r--r--dev-ruby/actionpack-xml_parser/actionpack-xml_parser-1.0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/actionpack-xml_parser/actionpack-xml_parser-1.0.2.ebuild b/dev-ruby/actionpack-xml_parser/actionpack-xml_parser-1.0.2.ebuild
new file mode 100644
index 000000000000..5d0dbebe3ebc
--- /dev/null
+++ b/dev-ruby/actionpack-xml_parser/actionpack-xml_parser-1.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="XML parameters parser for Action Pack (removed from core in Rails 4.0)"
+HOMEPAGE="https://github.com/rails/actionpack-xml_parser"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/actionpack-4.0.0:* <dev-ruby/actionpack-5:*"
+ruby_add_bdepend "test? ( >=dev-ruby/activesupport-4.0.0 )"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" Rakefile test/helper.rb || die
+ sed -i -e '1igem "actionpack", "~>4.0"' test/helper.rb || die
+}
+
+each_ruby_test() {
+ MT_NO_PLUGINS=true ${RUBY} -Ilib:test test/xml_params_parsing_test.rb || die
+}