summaryrefslogtreecommitdiff
path: root/dev-ruby/activeldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-17 06:49:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-17 06:49:08 +0000
commit2bf68d7062b64d9f815f3b8ce6942a66afe53b0d (patch)
treeac1e773aaa4d3575d18d178ae260cab963bbf64c /dev-ruby/activeldap
parentcd356b722fd8d162f02a5059fae1a66e00be52e3 (diff)
gentoo auto-resync : 17:03:2024 - 06:49:08
Diffstat (limited to 'dev-ruby/activeldap')
-rw-r--r--dev-ruby/activeldap/Manifest2
-rw-r--r--dev-ruby/activeldap/activeldap-7.0.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/activeldap/Manifest b/dev-ruby/activeldap/Manifest
index 8b931124d091..1c2fa33469ef 100644
--- a/dev-ruby/activeldap/Manifest
+++ b/dev-ruby/activeldap/Manifest
@@ -1,3 +1,5 @@
DIST activeldap-6.1.0.gem 227328 BLAKE2B 48cd393a294b677b373461701773d3d0c18cbe9ee5124bcbafe392ee664a0e1045feb2d808734988bfceaaf7ae7b276ea12615ae30bb8109d63daf4b6a8cbed5 SHA512 b8a8d1346d75ae1ddd15b919f2a7afbec3e62b4248144ece3e1324892899735b05aa221ecec7c07f6273f35a6ffdacf4858d57326fb9b8c096f358652ef0b99d
+DIST activeldap-7.0.0.gem 227840 BLAKE2B 2bf720efa60f2233180cf73a79da61058398a7409319c468ee96938091fd3d4eeebc904e3d8c55f51d1ca9a22f1b22e27554b78910065022ce9ebb92a883c256 SHA512 b4df5307583fc29abb74cdfd1d3b62f4bf03525e4a81397b32522ce84ee49f58fae27a7e9ba62490cfe49daa27be67440ccbaca25ba15553845d9e4a6e693bda
EBUILD activeldap-6.1.0-r1.ebuild 837 BLAKE2B aa0059d7b7ae1e42cf41d806be128753c1d86f090fd49808fddf873ae41e715e106e5a68880b1e557a066faf59da511791a831e1665c0cc63ac13416fd46cded SHA512 b377153f0a63c27aadce30ac68e8fd8faf00dd9b3991a6f3a4f75ef4c7d5ebac2d78218f3e423f29b257f88408e0bcb9d4794aa72dfd8c0ab493155c045014e2
+EBUILD activeldap-7.0.0.ebuild 833 BLAKE2B b94866af1c70520486fb13cb9cd6603cbfddf5b4e14f1e79e6ae8346ce4f9c3212d3e7b4e2fa28fa4e1156fefbf4c6698c179f1ae07e3ce91c0877932171157f SHA512 a622611a6c5e6e65d58837e30d5431c1f2ca963ace7040f234e744bf76e78438a0f724719db972eaeef201c46ecfe507ad0f7f381426a21a0dcb6ae06d57b9dc
MISC metadata.xml 348 BLAKE2B 9c4cf9542092aedd113d440228f34ec526e70bf0d81faefb3a22eb8464d1aa5f09d04cd0ba69a0c11a62654fd7b781c3e927eb76f28ffdf0c6825fd562938b8e SHA512 b7deb0a0b4c69059f15b97ec306ea62c9d001b1b581d0513e84d6865431216900133007c1c5eb462494f59dfc9f4545f5310e21e8a3b3990c61438a6499c5cfa
diff --git a/dev-ruby/activeldap/activeldap-7.0.0.ebuild b/dev-ruby/activeldap/activeldap-7.0.0.ebuild
new file mode 100644
index 000000000000..1540a3004f70
--- /dev/null
+++ b/dev-ruby/activeldap/activeldap-7.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="TODO doc/text/*"
+RUBY_FAKEGEM_EXTRAINSTALL="po"
+
+# Most tests require a running LDAP server
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+MY_P="${P/ruby-/}"
+DESCRIPTION="ActiveLDAP provides an activerecord inspired object oriented interface to LDAP"
+HOMEPAGE="https://github.com/activeldap/activeldap"
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+
+ruby_add_rdepend "
+ >=dev-ruby/activemodel-5.2.0:*
+ dev-ruby/builder
+ dev-ruby/locale
+ dev-ruby/ruby-gettext
+ dev-ruby/gettext_i18n_rails
+ || ( dev-ruby/ruby-net-ldap >=dev-ruby/ruby-ldap-0.8.2 )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc doc/text/*
+ dodoc -r examples
+}